Author Topic: v21.0.3.0 64-bit Win7: Losing Vim markers  (Read 680 times)

davew

  • Senior Community Member
  • Posts: 224
  • Hero Points: 6
v21.0.3.0 64-bit Win7: Losing Vim markers
« on: July 21, 2017, 11:55:58 am »
I am having a very frequent occurrence (although not always) of setting a vim marker and when I go back to it, it goes back to a previous marker location.

For example, I type mm to set marker 'm'. I see the green marker icon on the line in which I set it. I then navigate to another location in the same file and when I am finished, I press `m to go back to the marker and it goes back to an older location of the 'm' marker. When I go to the last place I set it, the marker is gone.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4637
  • Hero Points: 371
Re: v21.0.3.0 64-bit Win7: Losing Vim markers
« Reply #1 on: July 23, 2017, 01:14:08 pm »
Couldn't reproduce any issue. These key sequences use standard bookmark functions. When you press "mm", it sets a bookmark named "m". When you press "`m" it goes to the bookmark named "m". If you dock the bookmarks tool window, you can easily check what line number and file any bookmark is recorded on.

Double check that the bookmarks tool window shows the correct file and line number. If the green marker icon changes, that should mean it was updated. I'm pretty lost on this one.

davew

  • Senior Community Member
  • Posts: 224
  • Hero Points: 6
Re: v21.0.3.0 64-bit Win7: Losing Vim markers
« Reply #2 on: July 23, 2017, 01:24:17 pm »
Thanks Clark, I'll give that a shot. Yesterday, I watched the bookmark disappear as I jumped to another bookmark within view in the same buffer. Very odd that it doesn't always happen. I'll see if I can figure out what the sequence is.