Author Topic: Poor scroll performance with mouse wheel - 2016  (Read 313 times)

tedapke

  • Junior Community Member
  • Posts: 4
  • Hero Points: 1
Poor scroll performance with mouse wheel - 2016
« on: June 13, 2017, 09:00:55 pm »
I'm running v21.0.2.0 64-bit and I'm having problems scrolling through some (most) of the files in my project using the mouse wheel.  If I grab the scroll bar I can zoom through the file.   The editor will usually keep up with my typing, even when these problems are present.  Some days are worse than other.  I see this problem with files locally mounted on my SSD as well as remotely mounted on a network drive.

If I open the same file, without having a workspace open, the file scrolls smoothly.
My workspace has 27K files (.cpp, .h, .xml) in it.
I'm using a dual-core i7 with a Dell Mouse, HID-compliant default Microsoft driver on Windows 7.

Any help would be appreciated.
Thanks
Ted

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1831
  • Hero Points: 74
Re: Poor scroll performance with mouse wheel - 2016
« Reply #1 on: June 14, 2017, 12:31:45 pm »
What are the scroll wheel settings in Windows?

You said Dell Mouse, but I just want to verify we're talking about a real mouse, not a trackpad, correct?

tedapke

  • Junior Community Member
  • Posts: 4
  • Hero Points: 1
Re: Poor scroll performance with mouse wheel - 2016
« Reply #2 on: June 14, 2017, 02:58:54 pm »
Vertical Scrolling - 3 lines per notch

A mouse, not a trackpad although the Mouse Properties do bring up a properties window with a tab for the Dell Trackpad.  Verified that this is the properties for the mouse by changing 3 to 10 and observing the difference.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3664
  • Hero Points: 238
Re: Poor scroll performance with mouse wheel - 2016
« Reply #3 on: June 15, 2017, 05:55:30 pm »
What's the resolution of your monitor?

tedapke

  • Junior Community Member
  • Posts: 4
  • Hero Points: 1
Re: Poor scroll performance with mouse wheel - 2016
« Reply #4 on: June 16, 2017, 03:51:36 pm »
1900 x 1200

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3664
  • Hero Points: 238
Re: Poor scroll performance with mouse wheel - 2016
« Reply #5 on: June 16, 2017, 04:58:18 pm »
That's not a high resolution. 4k monitors tend to push the performance threshold.

Have you turned on Symbol coloring? It's not on by default. That would have a lot of overhead while scrolling.

Seems like some tagging related feature is slowing things down. Try turning off "Show info for symbol under mouse" (Languages>C/C++ or your language>Context Tagging). I'm guessing a bit. Could be that you are pausing just long enough for it to kick in before you are continuing to scroll.





Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2091
  • Hero Points: 259
Re: Poor scroll performance with mouse wheel - 2016
« Reply #6 on: June 22, 2017, 08:25:02 pm »
To factor out Symbol Coloring, if that is what you are using, try increasing the amount of time before symbol coloring kicks in.

To determine if Symbol Coloring is the culprit, simply turn it off temporarily and see if your scrolling works better:  View > Symbol Coloring > [uncheck] Enable Symbol Coloring

To adjust how quickly Symbol Coloring kicks in, go to:
Tools > Options > Editing > Context Tagging > Symbol coloring performance > Update after (ms) idle.  Give yourself a whole second, maybe that will help.

tedapke

  • Junior Community Member
  • Posts: 4
  • Hero Points: 1
Re: Poor scroll performance with mouse wheel - 2016
« Reply #7 on: July 11, 2017, 06:36:50 pm »
I think I "fixed" the problem by disabling "Show info for symbol under mouse".

Document->C/C++ Options->Context Tagging->Show info for symbol under mouse.

Thanks!