Author Topic: SlickEdit does not accept custom GDB  (Read 81 times)

yev15

  • New Community Member
  • Posts: 1
  • Hero Points: 0
SlickEdit does not accept custom GDB
« on: June 19, 2017, 01:53:08 pm »
The SlickEdit fails to add my custom GDB agent to debug configuration. It looks like for some reason the SlickEdit  is not able to read the GDB version:

"/usr2/eugenez/xt_gdb_cpu.csh" does not appear to be a compatible version of GDB.
The required version is GDB 5.1 or greater.
The identified version was "".:  Timed out waiting for response from GDB


I redirected GDB output to log file and i see that the version reported by my GDB is correct and should be compatible with SlickEdit:

ez{61}> cat output.txt
GNU gdb (GDB) 7.5.91 Xtensa Tools 11.0.4
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-unknown-linux-gnu --target=xtensa-elf".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
(xt-gdb) (xt-gdb) (xt-gdb) quit


What can i do to fix it? Is there and option to disable GDB version check by SlickEdit?



Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2064
  • Hero Points: 256
Re: SlickEdit does not accept custom GDB
« Reply #1 on: June 19, 2017, 04:44:21 pm »
Since GDB 5.1 is so far in the rear view mirror at this point, the good news is I'm going to take the version check out for the next release of SlickEdit.  That will solve whatever problems we are having parsing out the version from odd GDB builds.

In the meantime, I have a simple workaround for you.  In your SlickEdit configuration directory, there is a file named "debugger.xml".  Edit this file, copy one of the existing configurations, and add your new debugger configuration.  Restart SlickEdit, and you should be off and running.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2064
  • Hero Points: 256
Re: SlickEdit does not accept custom GDB
« Reply #2 on: June 19, 2017, 05:11:28 pm »
Also, I noticed two things after the fact here.

(1) Your GDB is a shell script.  Please make sure the shell script passes along the arguments that SlickEdit sends to GDB.  In particular, it is essential to turn on "-interpreter=mi".

(2) The error message about the version says it got a timeout waiting for a response from GDB.  This means that either your version of GDB did not respond the to "-gdb-version" MI command, or there is some other problem with the shell script, such that SlickEdit is not receiving the output from GDB on stdout.