Author Topic: Unable to paste. Copied data is in clipboard but paste not working. Windows 10  (Read 789 times)

viarand

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Hi,
I am currently using Slickedit v21.0.1.0 x64 version on Windows 10.
Facing a problem where I am not able to copy paste after some actions. I think locking the system or putting it in sleep mode with Slickedit open cause this.

I can see the copied data in the clipboard but paste does not work. Out of 10 copies, it might work for once. That is it.
Once this problem  happens, none of the following works and I need to reinstall slickedit to get this working.
I tried system restart, deleting the slickedit config directory, and loading the clipbd.e module. (Maybe I am not doing it in some right way)

Has anyone faced any issues like this? Is there any workaround/fix for this? I am unable to use slickedit at this point because of this.

I found one thread similar to it but thread went idle without solution on v19.0.1.1
https://community.slickedit.com/index.php?topic=11100.0

Thanks,
Vivek

Graeme

  • Senior Community Member
  • Posts: 2136
  • Hero Points: 263
It could be a Windows 10 bug.  Have you got the win 10 creator's update?  Does copy/ paste work in other applications?  You could try this clipboard manager - the pro version is cheap.
https://www.clipboardfusion.com/

Do you have Windows fast boot on?  If so, try turning it off and see if restart allows copy paste to work.
https://www.howtogeek.com/243901/the-pros-and-cons-of-windows-10s-fast-startup-mode/

Have you tried restarting explorer?
https://www.tenforums.com/tutorials/5970-restart-explorer-exe-process-windows-10-a.html

To force a re-compilation of clipbd.e you have to "touch" the file to a make the "ex" file out of date.  It may not make any difference but you could try this macro to compile and load clipbd.e.  You might want to copy clipbd.e to a working folder of your own and load it from there to get round the write permission problem.

Code: [Select]
_command void force_load() name_info(','VSARG2_REQUIRES_EDITORCTL|VSARG2_READ_ONLY)
{
   _save_file('+o');
   load();
}

If none of the above helps you could try running the slick debugger and see what the paste command in clipbd.e is doing.  Also try upgrading to slick 21.0.3.


viarand

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Thanks Graeme.
Let me try those when the issue pops up again.