Author Topic: Linux x64 3 way merge has no window max/min, exiting hides "save changes" dialog  (Read 302 times)

TKasparek

  • Senior Community Member
  • Posts: 182
  • Hero Points: 21
Ubuntu 16.04.2
It is really inconvenient to have to manually resize the window every time for 3 way merge and DIFFzilla instead of just hitting maximize. This doesn't look to be changing for SE 2017... Any comments from the SE team, I'm pretty sure these are available in Windows version.

Also, I've been consistently seeing that if I open a 3-way merge or diff and have changes but try to just x out of the program the "Do you wish to save changes ..." dialog is not in focus and hidden behind the merge/diff tool. I have to click away and back to get it in focus.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1959
  • Hero Points: 81
I will take a look at these.

TKasparek

  • Senior Community Member
  • Posts: 182
  • Hero Points: 21
Hey Dan,
Were you able to get anywhere on this?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1959
  • Hero Points: 81
I have not forgotten.  I will try to get it into beta 3.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1959
  • Hero Points: 81
Ubuntu 16.04.2
It is really inconvenient to have to manually resize the window every time for 3 way merge and DIFFzilla instead of just hitting maximize. This doesn't look to be changing for SE 2017... Any comments from the SE team, I'm pretty sure these are available in Windows version.
They seem to be there on Ubuntu 16.04 as well.  On the left side, there's a round button with an X, and another with a square. The square is maximize.  Do you not see this?  It's possible it's a window manager thing, but I'm using the default one.

Also, I've been consistently seeing that if I open a 3-way merge or diff and have changes but try to just x out of the program the "Do you wish to save changes ..." dialog is not in focus and hidden behind the merge/diff tool. I have to click away and back to get it in focus.

I can't reproduce this one either.  In fact, I can't make it drop behind.

What window manager are you using?

TKasparek

  • Senior Community Member
  • Posts: 182
  • Hero Points: 21
I usually use Mate. I just tried the default DE and Cinnamon. The default DE has the option for maximise but not minimize. Cinnamon and Mate do not have the options. Right clicking on the title bar to get the context menu shows that minimize and maximized is grayed out (maximize is available on default DE). This is the same behaviour for Diff/3 Way Merge/SE child windows

The second issue seems to only happen on Mate DE.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1959
  • Hero Points: 81
I'll take a look at this, but I can't promise anything since if it's a window manager issue.

TKasparek

  • Senior Community Member
  • Posts: 182
  • Hero Points: 21
Sounds good, thanks. Would you expect to be able to minimize on the default though?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1959
  • Hero Points: 81
I would think so, but we have done what we can to turn it on for diff.  It doesn't look like minimize is on for merge, so I can turn that on, but again, window manager.