Author Topic: SE22 B2 not coloring hex numbers correctly  (Read 950 times)

erik

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
SE22 B2 not coloring hex numbers correctly
« on: August 13, 2017, 06:21:47 pm »
The C/C++ and C# lexers (and maybe others) are not coloring hex numbers past the 0x part correctly. The digits after the x are colored as plain text, see attachment.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4690
  • Hero Points: 378
Re: SE22 B2 not coloring hex numbers correctly
« Reply #1 on: August 13, 2017, 07:09:41 pm »
Try a default config:

vs +new -sc <new-temp-dir>

If this fixes your problem (and it should), please zip up your old (21.0.3?) config directory without any of the subdirectories (or at least remove the big ones), zip it up, and post it here. If you are using the "cpp" and "CSharp" color coding profiles (Options>Languages>Application Languages>C/C++>Color coding), you can start with your already upgraded v22 config and just use the "Reset" button to remove the problematic changes. That way, you can keep most of your config changes.

Brandon

  • Community Member
  • Posts: 36
  • Hero Points: 5
Re: SE22 B2 not coloring hex numbers correctly
« Reply #2 on: August 15, 2017, 01:58:08 pm »
I don't know if this will help your problem or not, but I had a heck of a time getting my settings from 21.0.3 imported into beta 2 without color coding completely screwing up.  In my case it was LESS and the single line comment (//) that would work initially but then screw up on import.

So the first question is: are you trying to import settings?   

I always create a VS shortcut with the -sc switch as Clark said (because I prefer all my /config locally for portability) and wound up just deleting and reimporting everything individually until I got it to work (or saw it break).

I also found that - even when it appeared to be ok  - when I opened an existing workspace it would screw things up again.   Maybe I'm mistaken - but it seems that there may be something in the workspace files (.vtg and maybe .vpwhist) that can trigger a problem too.

So what I did was this:
1) after install, create a shortcut to make a local config using -sc switch (/config).   This is a fresh config (copy).
2) import all settings from 21.0.3 EXCEPT Languages (i.e. unchecked)
3) delete my workspace .vtg and .vpwhist before loading it

And then manually update language settings.

Seems to be working ... so far... except for one other issue I'll post about separately.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4690
  • Hero Points: 378
Re: SE22 B2 not coloring hex numbers correctly
« Reply #3 on: August 15, 2017, 02:21:42 pm »
it shouldn't be that hard. Please zip up your 21.0.3 config directory without the subdirectories to reduce the size and post it here. List the problems your seeing. I wouldn't expect opening a workspace to cause a problem. It's should be no different from opening the same files manually yourself.

If you already have a less color coding definition in v21, that could definitely mess up v22. You should reset that color coding profile.
« Last Edit: August 15, 2017, 02:27:09 pm by Clark »

Brandon

  • Community Member
  • Posts: 36
  • Hero Points: 5
Re: SE22 B2 not coloring hex numbers correctly
« Reply #4 on: August 15, 2017, 04:07:23 pm »
it shouldn't be that hard. Please zip up your 21.0.3 config directory without the subdirectories to reduce the size and post it here. List the problems your seeing. I wouldn't expect opening a workspace to cause a problem. It's should be no different from opening the same files manually yourself.

If you already have a less color coding definition in v21, that could definitely mess up v22. You should reset that color coding profile.


Not trying to hijack the OPs thread, but I can see it happen.   I just repeated the steps (deleted config, imported 21.0.3 options minus langs, then loaded workspace that I had ALREADY been working on with 22B2 and the LESS // syntax coloring was messed up).   So I did it all again, except this time I deleted vtg and vpwhist before loading the workspace, and the LESS file displays correctly.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4690
  • Hero Points: 378
Re: SE22 B2 not coloring hex numbers correctly
« Reply #5 on: August 15, 2017, 05:09:16 pm »
By deleting your vpwhist, no files are opened. Whatever is going on might have to do with opening and displaying certain files.
« Last Edit: August 15, 2017, 05:19:34 pm by Clark »