Author Topic: B3: Smart open "Date Modified" sometimes changes to "12:00AM"  (Read 709 times)

rowbearto

  • Senior Community Member
  • Posts: 1468
  • Hero Points: 111
B3: Smart open "Date Modified" sometimes changes to "12:00AM"
« on: September 06, 2017, 03:48:17 pm »
To reproduce:

In Smart Open, right click on the column headings and enable "Date Modified".

Type in the prefix of the name of a file that appears often in a project.

Click on the column heading for "Date Modified" multiple times, eventually you will see some of the dates turn to 12:00AM

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2369
  • Hero Points: 132
Re: B3: Smart open "Date Modified" sometimes changes to "12:00AM"
« Reply #1 on: September 06, 2017, 03:49:34 pm »
I will take a look at this.

rowbearto

  • Senior Community Member
  • Posts: 1468
  • Hero Points: 111
Re: B3: Smart open "Date Modified" sometimes changes to "12:00AM"
« Reply #2 on: September 08, 2017, 03:09:28 am »
I found a way to systematically reproduce this, using attached project.

Open SE with default config (-sc <empty_dir>), using an empty dir seems critical for reproducing, don't use a default config that already exists.

Open attached workspace: prj.vpw

In smart open, double click on the grandparent directory of prj.vpw (the parent of mainprj)

Type "main.cc" in smartopen to show all the main.cc files

Right click on the column headings and enable "Date Modified"

Notice that all dates are 12:00 AM

I did this on a Linux x64 Centos 7.2 machine, but maybe only Linux x64 needed? If centos needed, can use my VM (but need to install beta3) as instructed here:

https://community.slickedit.com/index.php/topic,15458.msg58927.html#msg58927
« Last Edit: September 08, 2017, 03:22:04 am by rowbearto »