Author Topic: vertical line column doesn't show up for xml  (Read 6467 times)

catphive

  • Community Member
  • Posts: 15
  • Hero Points: 0
vertical line column doesn't show up for xml
« on: August 13, 2008, 07:57:59 pm »
I have the vertical line column in Tools->Options->Appearance->General->Vertical Line Column set to 80 so I can see when I'm going over 80 columns.

For some reason this doesn't show up for XML files on my slickedit 13 install. Is there some way to fix this?

Thanks,
Brendan

Phil Barila

  • Senior Community Member
  • Posts: 742
  • Hero Points: 61
Re: vertical line column doesn't show up for xml
« Reply #1 on: August 13, 2008, 08:11:51 pm »
Do you have a proportional display font for xml?  The red line only works on mono fonts.

catphive

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: vertical line column doesn't show up for xml
« Reply #2 on: August 13, 2008, 09:52:30 pm »
Where do I control the font for XML? It doesn't seem to be effected by the font I use for other languages.

hs2

  • Senior Community Member
  • Posts: 2735
  • Hero Points: 287
Re: vertical line column doesn't show up for xml
« Reply #3 on: August 13, 2008, 09:58:59 pm »
IIRC it's 'Appearance>Fonts: Unicode Source Windows'. HS2

catphive

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: vertical line column doesn't show up for xml
« Reply #4 on: August 13, 2008, 10:12:14 pm »
Well, I did get it switched to bitstream vera sans mono like the rest of my c++ and java source where the vertical line works fine, but no dice. The vertical line column still will not show up in XML files.

Any ideas?

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: vertical line column doesn't show up for xml
« Reply #5 on: August 13, 2008, 11:16:13 pm »
See here, you probably need to go to the Tools|Options|Appearance|Colors node and in the Font Style group make sure "Use fixed spacing for bold and italic fixed Unicode fonts" is checked.

catphive

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: vertical line column doesn't show up for xml
« Reply #6 on: August 14, 2008, 02:44:03 am »
Wierd.

At least under linux slickedit 13.0.1 there is no such "font styles group" under Tools|Options|Appearance|Colors. There is deifnitely no checkbox to force fixed width fons (although I did choose a monospace font).

What version of slickedit do you have that you can see this?

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: vertical line column doesn't show up for xml
« Reply #7 on: August 14, 2008, 03:16:45 am »
13.0.1 r20 on Vista, see screen shot below.
Maybe it's different depending on the platform.
Look for something similar -- something is likely not fully configured to use monospace.

catphive

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: vertical line column doesn't show up for xml
« Reply #8 on: August 20, 2008, 07:14:22 pm »
Yup, that check box is definitely missing on Slickedit for linux 13.0.1.0.
That's the only difference I've seen to far in the UI (I've seen the windows version before). Pretty wierd, maybe it is because fonts are more difficult to configure on linux or something?

Thanks anyway