Author Topic: unresponsive during workplace search  (Read 536 times)

ChuckInDodgeville

  • Community Member
  • Posts: 24
  • Hero Points: 1
unresponsive during workplace search
« on: September 13, 2017, 02:49:10 pm »
I have a fairly large workspace.  I just did a "find all references" to a highlighted function.  The scope was set to "current workspace".  That was an error.  I really only wanted to search the file.  But the cursor went to busy and the application is unresponsive.  I should be able to cancel the search.  I wouldn't mind waiting if I could do something else, but the app goes "gray" and I can't do anything until it finishes searching.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4618
  • Hero Points: 368
Re: unresponsive during workplace search
« Reply #1 on: September 13, 2017, 03:18:55 pm »
How many files are in your workspace?

ChuckInDodgeville

  • Community Member
  • Posts: 24
  • Hero Points: 1
Re: unresponsive during workplace search
« Reply #2 on: September 13, 2017, 06:45:49 pm »
There are 9435 files in the project. 
I selected all of them in the projects pane and right clicked and then waited through the spin.  A dialog came up asking whether I wanted to remove one named file.  I clicked "no to all" and now it's removing many.  In the end I think it removed all the C files. 

I'm sure there is a better way to factor this.  I get the idea there is a way to put multiple projects in a workspace?  I've always just added the whole directory (.c, .h) to the project. 

I don't recall seeing this kind of blocking delay in SE 17.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4618
  • Hero Points: 368
Re: unresponsive during workplace search
« Reply #3 on: September 13, 2017, 07:32:16 pm »
Your project isn't that big.

Is the tag file local?

Are your source files local?

Are you files on a local SSD?

If you do the same reference command twice in a row, is it faster than second time. It can take a while to cache a lot of the tag file the first time.

ChuckInDodgeville

  • Community Member
  • Posts: 24
  • Hero Points: 1
Re: unresponsive during workplace search
« Reply #4 on: September 13, 2017, 08:39:24 pm »
Everything is on a spinning HDU.  It seems slower than SE 17, but I will move the SSD update up the list.