Author Topic: Issue with backspace not removing working properly  (Read 494 times)

TKasparek

  • Senior Community Member
  • Posts: 204
  • Hero Points: 25
Issue with backspace not removing working properly
« on: September 22, 2017, 10:16:05 pm »
I've hit an issue several times with backspace not correctly removing a character. In the following example:
ABCDEF
If I place the cursor between D and E and hit backspace twice I would have:
AB  ED
The characters are cleared instead of removed.

I haven't nailed it down what gets me into this mode. The only way to recover has been to relaunch SE and then everything works fine again.
Quote
SlickEdit Pro 2017 (v22.0.0.3 64-bit)

Serial number: FE35867_BETA
License type: Beta License
License expiration: 2017-11-06 18:00:00
License file: /home/tom/Programs/slickedit-pro2017beta3/bin/slickedit.lic

Build Date: September 04, 2017
Emulation: CUA

OS: Linux
OS Version: Ubuntu 16.04.3 LTS
Kernel Level: 4.4.0-96-generic
Build Version: #119-Ubuntu SMP Tue Sep 12 14:59:54 UTC 2017
Processor Architecture: x86_64

X Server Vendor: The X.Org Foundation
Memory: 45% Load, 12864MB/28296MB Virtual
Shell Information: /home/tom/Programs/slickedit-pro2017beta3/bin/secsh -i
Screen Size: 1920 x 1080, 1920 x 1080

Project Type: Cpp
Language: .hpp (C/C++)
Encoding: Automatic

Installation Directory: /home/tom/Programs/slickedit-pro2017beta3/
Configuration Directory: /home/tom/.slickedit/22.0.0/
Migrated from: /home/tom/.slickedit/21.0.3/
Spill File: /tmp/$slk.tom.20882

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4673
  • Hero Points: 375
Re: Issue with backspace not removing working properly
« Reply #1 on: September 23, 2017, 05:28:27 pm »
Set the macro variable def_pull to 1 (Macro>Set Macro Variable...). I don't know where this option is in the GUI. When you restarted SlickEdit, you were in insert mode. Before you exited, you were in replace mode with def_pull set to 0.
« Last Edit: September 24, 2017, 02:05:20 am by Clark »