Author Topic: Access Denied: VSlick.STA  (Read 1237 times)


  • Senior Community Member
  • Posts: 1902
  • Hero Points: 184
  • Text
Access Denied: VSlick.STA
« on: September 27, 2017, 07:58:17 pm »
I get this *a lot* with V22:
SlickEdit Pro
Failed to save configuration to 'C:\users\joe\Documents\SlickEdit\22.0.0\vslick.sta'.

Access denied

I do have Tools > Options > Application Options > Exit -> SaveConfig == Immediately.

If I have two instances of Slick (the 2nd with "vs +new"), *both* of them complain with that error incessantly.

Seems that the 2nd instance holds on to that file with FILE_SHARE_READ, preventing the first instance from writing to it at all.

I thought it used to be that only the 2nd instance (vs+new) was not allowed to write to this file.

This also happens when I have VS running, then I run "vsdiff" from the command line -- vsdiff then gives this same error over and over.

#1: Add a "Stop complaining about this" checkbox.

#2: A "+new" instance probably should be content not saving state, without complaining or interfering with the 1st instance.

#3: A "+new" instance could automatically copy vslick.sta to vslick_2.sta and make the world a more beautiful place

#4: The Slick title bar should indicate which instance it is somehow.
Maybe each "+new" instance could say "filename.... - SlickEdit Pro (2)"

This problem has plagued Slick for many years.
It makes it really hard / annoying to have multiple instances of Slick -- There is nothing automatic about it!


  • New Community Member
  • Posts: 2
  • Hero Points: 0
Re: Access Denied: VSlick.STA
« Reply #1 on: October 06, 2017, 05:59:51 pm »
This has been happening very frequently for me recently as well, although I am on v20.0.3.0 (so maybe v22 beta discussion is the wrong place to comment) and only have one instance running.  In my case, vslick.sta gets deleted.  I'm assuming SlickEdit deletes the old file and tries to write the new file and just fails somehow.  I setup a scheduled job to make a backup copy of vslick.sta every minute, and put it back if it gets deleted, but unfortunately that doesn't help.

Also, once it gets into this state, I can't close SlickEdit normally.  If I try, I get a dialog that says:

Spill file I/O error.
The spill file is currently set to .
 To change the location of the spill file, go to Tools > Options > Application Options > Virtual Memory.
[Retry] [Cancel]

(Note that I haven't changed the spill file, the Spill file path entry in Tools > Options > Application Options > Virtual Memory is blank.)
The Retry button does nothing, by which I mean either nothing actually happens, or it just shows the same dialog again, I can't really tell.  The Cancel button just results in another dialog that says:

Error reading file
The OK button just shows the first dialog again, ad nauseam.  Eventually I have to kill vs.exe via task manager.