Author Topic: SE 22.0.0.9 crash when search replace "kill" with "kill -9"  (Read 1138 times)

rowbearto

  • Senior Community Member
  • Posts: 1379
  • Hero Points: 104
SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« on: October 23, 2017, 05:54:15 pm »
Open the attached file in SE.

Using BigFind/Replace, search "kill" and replace with "kill -9". Press "Go", SE crashes

mjdl

  • Senior Community Member
  • Posts: 139
  • Hero Points: 16
  • SE 23.0.2 hotfix 2 x64 Windows 10 v1903
Re: SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« Reply #1 on: October 23, 2017, 06:20:37 pm »
FYI: On SE 22.0.0.8 x64 on Windows 7 x64, search/replace operation on your file succeeds.

rowbearto

  • Senior Community Member
  • Posts: 1379
  • Hero Points: 104
Re: SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« Reply #2 on: October 23, 2017, 06:23:48 pm »
Yeah and it worked for me too on Windows 7 x64 with 22.0.0.9

It may be particular to Linux (I'm in Centos) or particular to my configuration.

If SE team can't reproduce on Linux, I will send my configuration.

rowbearto

  • Senior Community Member
  • Posts: 1379
  • Hero Points: 104
Re: SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« Reply #3 on: October 23, 2017, 06:25:13 pm »
I uploaded my config to support.slickedit.com under "killdashninecrash".

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4739
  • Hero Points: 383
Re: SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« Reply #4 on: October 24, 2017, 12:41:27 am »
Replace completes fine for me after I've imported your config on Ubuntu. I wouldn't expect a feature like this to be dependent on a particular Linux distrib.

Can you reproduce this with a clean config on Linux? If not, can you reproduce this with a clean config after importing the options you've uploaded?

rowbearto

  • Senior Community Member
  • Posts: 1379
  • Hero Points: 104
Re: SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« Reply #5 on: October 24, 2017, 03:36:28 am »
I tried this in the VM I created for you for the other issue. SE does not crash there. So I don't know what is special about the setup I have where it crashes. I can't seem to get crash dumps out - I'll try a little more to get crash dumps.

rowbearto

  • Senior Community Member
  • Posts: 1379
  • Hero Points: 104
Re: SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« Reply #6 on: October 24, 2017, 04:17:39 am »
I found a way to reproduce this reliably in the CentOS virtual machine that I sent for the other issue.

First, modify (you can run SE using typing "vsl" at konsole promtp) the /home/setest/pen/bin/vsl file, change line 82 from:

SE_CONFIG_DIR="${SE_CONFIG_PARENT_DIR}/config2"

to

SE_CONFIG_DIR="${SE_CONFIG_PARENT_DIR}/config"

(basically change from "config2" to "config" directory).

Exit SE and relaunch it by typing "vsl" at konsole prompt.

In the "Search" window (not search/replace), check both the "list all occurrences" and "List current context" box. This is important to reproduce the issue.

Then, open the "tst" file, go into the Replace window and do the search "kill" and replace with "kill -9" and then do "go"

This causes SE to crash every time.
« Last Edit: October 24, 2017, 04:29:09 am by rowbearto »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4739
  • Hero Points: 383
Re: SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« Reply #7 on: October 25, 2017, 01:09:51 pm »
Reproduced. You need just the right combination of options. I can reproduce this on Windows. You must have "List current context" AND "List replaced matches" checked AND be editing a file which has a proc_search function for listing context (instead of a C++ implementation). "Wrap at beginning/end" doesn't need to be checked.
« Last Edit: October 25, 2017, 02:45:15 pm by Clark »

rowbearto

  • Senior Community Member
  • Posts: 1379
  • Hero Points: 104
Re: SE 22.0.0.9 crash when search replace "kill" with "kill -9"
« Reply #8 on: October 25, 2017, 01:13:35 pm »
Glad that you found it!