Author Topic: Java 9 and Live Errors  (Read 82 times)

rygaard

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Java 9 and Live Errors
« on: December 06, 2017, 01:14:08 am »
Is anybody using Live Errors with Java 9 on Windows?  I'm having difficulty.

I had Live Errors with Java 8 working just fine, and I'm trying to upgrade my project to Java 9.

I'm using the "Java Build and Runtime Options" dialog box, with the "Live Errors" tab selected.  I am able to change the "Path to JDK 6 or later" field from
   C:\Program Files\Java\jdk1.8.0_66\
to
   C:\Program Files\Java\jdk-9.0.1\
with no problems.  When I click the "OK" button, I get an error message window saying
   Path to JDK 1.6 or later must be valid in order to use Live Errors.

I am confident that the new path is valid because (1) it is the default path chosen by the Oracle installer that installed the JDK, (2) all of my other software works just fine with this path (3) my SlickEdit project builds just fine with this path.

Am I making some mistake, or is this a problem with SlickEdit?

Thanks,
Chris

P.S.  I have a very similar problem with SlickEdit on Macintosh with Java 8.  Based on another posting on this forum from years ago, I don't have a lot of hope that this can be resolved.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4031
  • Hero Points: 267
Re: Java 9 and Live Errors
« Reply #1 on: December 06, 2017, 10:49:33 pm »
Java live errors will support java 9 on windows for v22.0.1 which will be out soon.