Author Topic: [Solved] New scala sbt project hangs  (Read 1016 times)


  • Community Member
  • Posts: 44
  • Hero Points: 7
[Solved] New scala sbt project hangs
« on: January 03, 2018, 01:20:31 pm »
When I create a new Scala sbt project I get a dialouge that asks for a sbt installation. I have my sbt installation in /home/myhomedir/bin and the dialouge accepts /home/myhomedir/ as a valid sbt path. Then when I hitt the next button VS hangs/frezes.

Is this a bug?

Here is my VS info:
SlickEdit Pro 2017 (v22.0.1.0 64-bit)
Licensed number of users: Single user
License file: /home/myhomedir/usr/slickedit17/bin/slickedit.lic
Build Date: December 12, 2017
Emulation: CUA
OS: Linux
OS Version: Fedora release 25 (Twenty Five)
Kernel Level: 4.13.16-100.fc25.x86_64
Build Version: #1 SMP Mon Nov 27 19:52:46 UTC 2017
Processor Architecture: x86_64
X Server Vendor: Fedora Project
Memory: 12% Load, 1672MB/13003MB Virtual
Shell Information: /home/myhomedir/usr/slickedit17/bin/secsh -i
Screen Size: 1920 x 1200
Project Type: Single file project - Other
Language: .sbt (Plain Text)
Encoding: Automatic
Installation Directory: /home/myhomedir/usr/slickedit17/
Configuration Directory: /home/myhomedir/.slickedit/22.0.1/
« Last Edit: January 03, 2018, 11:07:05 pm by Glajan »


  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1238
  • Hero Points: 119
Re: New scala sbt project hangs
« Reply #1 on: January 03, 2018, 02:20:51 pm »
At that point it should be trying to get the task lisk from sbt, which usually only takes a couple of seconds.  If sbt doesn't already have the version of scala pinned in the generated build.sbt file, it may download those dependencies here too.  While it shouldn't make the UI lock up, with the current design, we are stuck waiting for the task list, as we need that to be able to generate the project files.

Did you have to kill SlickEdit?  If not, is there anything in the Output tab? 

What happens if you go to the command line, cd to your project directory, and run this: sbt -J-Djline.terminal=None tasks -V   Does it complete, and what is the output you get from it?


  • Community Member
  • Posts: 44
  • Hero Points: 7
Re: New scala sbt project hangs
« Reply #2 on: January 03, 2018, 11:06:27 pm »
I had some strange file locking. Upgraded to Fedora 27 and now it works.