Author Topic: Copying and pasting a file to the same folder fails & deletes the initial file.  (Read 1032 times)

TMesch

  • New Community Member
  • Posts: 1
  • Hero Points: 0
I am using SlickEdit Pro 2016 (v21.0.1.0 32-bit) on CentOS. 

1. Using the file explorer window in Slick Edit Pro, labelled "Open".
2. Right click on a file in the upper part of the window and select Copy.
3. Right click in the same region of the window and select paste.

Expected Result: I expected a copy of the file to be created with a prefix of "Copy of <original filename>"

Actual Result: I get an error stating the file failed to copy.  When I dismiss the error message, I find the original file is then deleted.

P.S. Sorry if this is a duplicate.  I didn't see another report on it.

Graeme

  • Senior Community Member
  • Posts: 2107
  • Hero Points: 254
I wonder why posting to an archived read-only forum works.

I can't reproduce the problem on Windows 10.  Maybe it's a CentOS problem.  Do any other of your applications have this problem?

mwb1100

  • Senior Community Member
  • Posts: 144
  • Hero Points: 13
2. Right click on a file in the upper part of the window and select Copy.

When I try this on Linux Mint 18.2 with SE Pro 2017 22.0.0.4 x64, I get a dialog box asking me to enter a directory to copy the file to.  And if I have copied a file to the clipboard using the system's file browser, I don't get a "Paste" option when I right click in that SE Window.

Did the clipboard operations get removed from that right-click menu in SE 2017?