Author Topic: Vertical Red Line  (Read 706 times)

kafolske

  • Community Member
  • Posts: 14
  • Hero Points: 0
Vertical Red Line
« on: February 09, 2018, 12:37:54 am »
Why is there a vertical red line in my editor at column 72?  I can't find the setting that makes it go away and I can't find any information about it on the forums. 


LBCEi

  • Senior Community Member
  • Posts: 162
  • Hero Points: 11
Re: Vertical Red Line
« Reply #1 on: February 09, 2018, 01:43:26 am »
This is controlled by Tools>Options>General>Vertical Line Columns.  Set it to zero to suppress the display of a vertical line.

kafolske

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: Vertical Red Line
« Reply #2 on: February 09, 2018, 06:53:58 pm »
I couldn't find a Tools>Options>General setting.

Do you mean Tools>Options>Appearance>General>Vertical Line Column?

I have that set to zero but the line is still there.

LBCEi

  • Senior Community Member
  • Posts: 162
  • Hero Points: 11
Re: Vertical Red Line
« Reply #3 on: February 09, 2018, 07:06:38 pm »
Yes, that is what I meant.  It works for me (the line goes away when I change that setting to zero).  I am using v21.0.1.0.  What release are you using?

kafolske

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: Vertical Red Line
« Reply #4 on: February 09, 2018, 07:10:04 pm »
v16.0.3.0

kafolske

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: Vertical Red Line
« Reply #5 on: February 09, 2018, 07:12:19 pm »
I just tried an experiment and put a non-zero value in that setting.  I now how two lines.  The original one and the one at the new location.

My red line must be from another setting.

LBCEi

  • Senior Community Member
  • Posts: 162
  • Hero Points: 11
Re: Vertical Red Line
« Reply #6 on: February 09, 2018, 07:22:12 pm »
Interesting.  I'm afraid I'm stumped.  Hopefully someone else can help.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1150
  • Hero Points: 106
Re: Vertical Red Line
« Reply #7 on: February 09, 2018, 07:39:07 pm »
Is the Truncation line enabled for that document?  If go the Document > <current document modename> Options..., in the General section for that mode, there is a Truncation line length settings which prevents editing the columns beyond the truncation length.  Useful for some mainframe languages which restrict column lengths, but not usually enabled for most document modes.  You can turn it off there if it is set for that language type.  There is Slick-C command (trunc) which can turn on the truncation line for an individual file, you can use trunc 0 on the SlickEdit command line to turn it off.

kafolske

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: Vertical Red Line
« Reply #8 on: February 09, 2018, 08:01:57 pm »
Thanks Lee.  That helped.  I couldn't find the current document name in the document dialog, but your suggestion lead me to look at the language settings of the file.  As you mentioned, the Truncation line setting was set for that file type.

I changed that and the line was removed.  The text from the line location to the end of line is still colored differently, but I can sort that out.

Thanks!

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1150
  • Hero Points: 106
Re: Vertical Red Line
« Reply #9 on: February 09, 2018, 08:49:42 pm »
Is the current language mode for that file Cobol or is using Cobol color coding?  Cobol has special color coding rules for columns 1-7 and 73-80+, that may be what you are seeing at the end of the line.

kafolske

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: Vertical Red Line
« Reply #10 on: February 12, 2018, 05:37:13 pm »
IT is a .s file and looks to have the IBM assembly language format applied.