Author Topic: RO command line ignored  (Read 347 times)

dunkers

  • Senior Community Member
  • Posts: 603
  • Hero Points: 27
RO command line ignored
« on: March 09, 2018, 10:30:08 am »
I am starting SE with the -sallowopenrw command line parameter, which is supposed to make it open files in RO mode. On starting, the previous project is reloaded and all files are RW.

I am using this instance of SE as a reference so don't anything I do in it to make changes. I also use the -snoconfig parameter to prevent writes to the config directory, and that works as advertised.

Is there some way to make any file RO when opening this instance of SE? An auto-executed macro won't cut it since that would affect the working instance too.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4560
  • Hero Points: 353
Re: RO command line ignored
« Reply #1 on: March 09, 2018, 06:40:39 pm »
The docs for -sallowopenrw are totally wrong. Sorry for the confusion. This option will be removed from the docs because no one should use this option unless the SlickEdit support staff tells you to (it's a work around for a bizarre network file system performance problem).

There isn't any kind of invocation option for all files to be opened RO.

dunkers

  • Senior Community Member
  • Posts: 603
  • Hero Points: 27
Re: RO command line ignored
« Reply #2 on: March 09, 2018, 06:45:26 pm »
OK, thanks. That sorts that one out :)

Any chance for adding this kind of feature? Jolly useful when one is browsing code in one window and editing code in another.