Author Topic: Some Formatting Options not working  (Read 253 times)

SeeCwriter

  • Senior Community Member
  • Posts: 111
  • Hero Points: 0
Some Formatting Options not working
« on: June 22, 2018, 03:25:07 pm »
I am using SE v22.0.2.1, with hotfix rev 6. I am editing C source code, but the file extension is required to be .lib. I used the File Extension Manager to associate .lib files with C/C++. This has worked in the past, but I am noticing some editing features that no longer work as before.
For example, on the Options->Languages->All Languages->Formatting dialog, I configured tabs to indent with spaces at an indentation of 3. When a line is empty, if I hit tab, it will indent the right amount. But if there is already text on the line, it will only indent by 1. The "Indent with tabs" checkbox is always filled with a solid color. When I click on it so the checkbox is white (not filled), close the Options window, and reopen it, the checkbox is filled again.
For the Begin/End style section, I have it set to "next line". But when I enter an opening brace, it always puts it on the same line, and the closing brace on the next line.
When I look at Options->Languages->All Languages->Application Languages->C/C++ Formating, it shows the sample code formatted as I want.
Also, Adaptive Formatting is disabled.

Graeme

  • Senior Community Member
  • Posts: 2136
  • Hero Points: 263
Re: Some Formatting Options not working
« Reply #1 on: June 23, 2018, 05:26:40 am »
I can't really reproduce this.
Quote
But if there is already text on the line, it will only indent by 1
Can you give an example of some text and say where the cursor is when you press tab.

Quote
For the Begin/End style section, I have it set to "next line".
Whereabouts in the options dialog is this setting?


Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4405
  • Hero Points: 331
Re: Some Formatting Options not working
« Reply #2 on: June 24, 2018, 03:36:08 am »
The "Indent with tabs" checkbox is always filled with a solid color. When I click on it so the checkbox is white (not filled), close the Options window, and reopen it, the checkbox is filled again.

Certain languages (Makefile I think) must have indent with tabs on. That’s why the check box is filled in. I can’t comment on your other issues. Not enough info.