General > Community Forum

Error Creating Directory Entry many popups when starting or doing things

(1/2) > >>

Kork:
SlickEdit 2013 (v18.0.1.2 64-bit)
Win 7 Enterprise 64-bit


This started today (reboot after weekend) so I don't know what's going on.

It pops up a little window with "Error Creating Directory Entry".

This happens in these situations:

1. Starting Slick Edit (sometimes)
2. Searching big directories recursively (which makes the search "stuck" somewhere.)

If I click Ok, the search continues, but I usually encounter 5-6 of these stuck popups.

I tried deleting everything in My Slickedit Config under Documents.  Slick Edit is reset to factory more or less (you would know this; I don't) and it wants to drive me through a setup wizard.

Anyway, whatever the problem is, it isn't in that Documents folder.

Also, I have no *.stu files, which is the only other reference I can find using Google, on this site.  So both threads I can find, one from 2006, and one from 2014, do not have a working solution (anymore.)

Kork:
Here's a little more info on the search part of it anyway.

Sometimes it gets stuck on a file and puts up that popup.  Click Ok, pops up again, click Ok again, and then the search window says:

Failed to open:  (some path)\some file.c or .h (which is the filter I'm using)

However, Slick Edit can indeed open those files.  You can copy the path and open it and boom, open in Slick Edit.  Indeed, even if the file is already open in Slick Edit, it happens again.

You should put an AI button on that popup with the text we can click:  "Are you sure you can't open it?  It's open right there behind you inside of you!" :) :) :)

Graeme:
How long have you been using slickedit for  - since 2013?
Does the error happen every single time you search recursively in a big folder?
How many files and folders in the big folder?
Are you doing a "background search"  - if so, try swapping to foreground search - there's a checkbox in the find/replace dialog.
Have you tried running a check-disk on your hard drive?
Are there any errors showing in the system event viewer when you get this problem?

Sometimes deleting a file called vslick.sta (with slick closed) can help but if you already tried deleting your entire config folder than deleting vslick.sta won't help.

Kork:
This has only been going on for a few weeks.  I have been using Slick Edit for 6 months now.

What's the empty directory it's failing to create, and why?

Does Slick Edit create a parallel tree in some temp folder somewhere as it's traversing the real tree?

Kork:
Let me ask a different question -- Slick Edit is creating temporary files somewhere.  Where is this setting so I can see if (Slick Edit Temp Path) + (my file path) > 255?

I want to redirect it to c:\tmp\ and see if that fixes it.

Navigation

[0] Message Index

[#] Next page

Go to full version