Author Topic: Cursor shape doesn't change on insert-toggle  (Read 483 times)

kenl

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Cursor shape doesn't change on insert-toggle
« on: September 19, 2018, 08:00:38 pm »
Hello folks,

SlickEdit Pro 2017 (v22.0.0.9) on macOS Version: 10.13.6

Using macOS emulation (but I have tried others as well).  When I toggle insert mode (from insert to replace and back), my cursor shape does not change.  It remains a thin vertical bar, although the actual function does change from insert to replace mode.  The only way I can tell that I have changes modes is by checking the lower right corner indicator ("INS" vs. "REP")

The cursor-shape command returns:
-v 450 1000 750 1000 450 1000 750 1000

I've played a bit with that based on some things I've seen online, but to no effect.

Any ideas or experiments appreciated!

Cheers,
Ken

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4894
  • Hero Points: 399
Re: Cursor shape doesn't change on insert-toggle
« Reply #1 on: September 21, 2018, 11:41:22 am »
You need to remove the -v on the front.

If you are using this feature to emulate Brief, I'm pretty these settings are what you want:

100 1000 830 1000 100 450 500 1000

If not, just remove the -v from the default settings.

Cursor shape is ignored for proportional fonts but I suspect you're using a fixed font.

kenl

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Re: Cursor shape doesn't change on insert-toggle
« Reply #2 on: September 26, 2018, 01:49:08 pm »
Awesome, that worked.  Thanks so much.

Ke