Author Topic: Issue in Buiding Dependeny projects  (Read 158 times)

ssoma

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Issue in Buiding Dependeny projects
« on: July 27, 2018, 01:41:07 pm »
Hi,
Iam using SlickEdit 2013 (v18.0.1.2 64-bit) with my projects configured with external build tools using the tool commands. When I compile individual projects there is no issue on how the command is generated using the include and library paths configured. But if i compile main project which includes dependencies projects command generated is different and is causing my build script to fail in parsing the command. Below are the commands generated when compiled individually and when compiled from dependencies.
Under project properties-> tools-> for build we are using: buildx -auto -c%b -pBF %i -o%libs ..\%rn%re

Command generated when build for individual is:
buildx -auto -cRelease_607 -pBF "-IC:\work\Sample Project\Workspaces\Sri\Libraries\RTOS\Headers" "-IC:\work\Sample Project\Workspaces\Sri\Libraries\RTOS\Headers" -o..\Libraries ..\RTOS.vpj

Command generated when build from dependencies:
buildx -auto -cRelease_607 -pBF -IHeaders -I"C:\work\Sample Project\Workspaces\Sri\Libraries\RTOS\Headers" -o..\Libraries ..\RTOS.vpj

As we see the Command generated when build from dependencies include directectory is passed with double quotes which is different when build individual. Is there a way that we can fix it so the generated command is unique in both configuration builds

Thanks
Sri