Author Topic: How do I turn off case sensitivity in project-load window in 12.0.1?  (Read 4789 times)

erik

  • Junior Community Member
  • Posts: 9
  • Hero Points: 0
Okay, so I'm really lazy and just type filenames without looking/thinking. But the case sensitivity in 12.0.1 is an inhibitor. Can I turn it off?

Thank you!

hs2

  • Senior Community Member
  • Posts: 2752
  • Hero Points: 291
Re: How do I turn off case sensitivity in project-load window in 12.0.1?
« Reply #1 on: June 01, 2007, 01:25:16 pm »
@erik: For the time being you can hack tbfilelist.e - FileListFilterFiles() [line 1803]: '#if 1' -> '#if 0'.
You'll get a performance penalty but maybe your lists are not that huge...

@SlickTeam:
I'd also appreciate if you could add sth. like FILELIST_IGNORECASE (def_filelist_options) and support it in the '_FilterTreeControl()' (which curr. also doesn't support the FILELIST_PREFIX_MATCH option).

HS2

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5957
  • Hero Points: 467
Re: How do I turn off case sensitivity in project-load window in 12.0.1?
« Reply #2 on: June 01, 2007, 05:12:32 pm »
I think this should be case insensitive by default.  We are looking into this.

Clark

hs2

  • Senior Community Member
  • Posts: 2752
  • Hero Points: 291
Re: How do I turn off case sensitivity in project-load window in 12.0.1?
« Reply #3 on: June 01, 2007, 07:42:32 pm »
Great Clark !
CaSe sensitivity is the last issue preventing me from using the new Files TB (I'm still using my legacy sellist powered list-buffers/-projects macros).
Right - it's now incredibly fast and I think the revamp of that functionality was really worth the effort, right ?
If you could add the missing prefix match mode (it's sometimes useful) and configurable CaSe sensitivity as mentioned before it's perfect (for me).
The wildcard support is also a very useful feature (which I do not support in my commands).
However, I think it's time to give HP for this fantastic improvement of the product :)

HS2

ahodsdon

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: How do I turn off case sensitivity in project-load window in 12.0.1?
« Reply #4 on: June 12, 2007, 11:52:07 pm »
@HS2: I'm unable to get your work-around to work. I naievely went in and edited "C:\Program Files\SlickEdit 2007\macros\tbfilelist.e". I suspect, though, that I need to compile it in order for VS to use it. Macro > Unload Macro, Macro > Load Macro didn't seem to do it. Nor did quiting and restarting.

Any other thoughts?

hs2

  • Senior Community Member
  • Posts: 2752
  • Hero Points: 291
Re: How do I turn off case sensitivity in project-load window in 12.0.1?
« Reply #5 on: June 13, 2007, 09:13:13 am »
@ahodsdon:
That's strange. You did the same things as I did.
Ok - just to be really sure:
After the patch the code in effect should look like this:
Code: [Select]
static void FileListFilterFiles(_str filter_re,boolean prefixMatch=false)
{
#if 0 // 1 -> 0 for CaSe sens. WA
   _FilterTreeControl(filter_re,prefixMatch);
   _TreeRefresh();
   return;
#else
   // search options for comparing file names
   // Want this to be case insensitive even on UNIX
   filter_opt := '&i';
  ...

Please check the context menu of the Files TB for other options (prefix match etc) too.

There is no need to exit/re-start SE. Close/activate of the TB should be sufficient. The change imm. takes place after loading 'tbfilelist.e'. This could also be done via 'load' command on cmdline/shortcut which loads the curr. edited module.

BTW: It's sometimes better to delete the <module>.ex file manually and just load the module instead of unloading / loading it to force a re-compile. And it's anyway not necessary after edit/save.
Some of the modules contain timer triggered functions and unloading them even for a short period of time may lead to problems (e.g. lots of error popups,stack dumps).

Good luck,

HS2

ahodsdon

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: How do I turn off case sensitivity in project-load window in 12.0.1?
« Reply #6 on: June 13, 2007, 06:22:54 pm »
Deleting the the compiled file and reloading did the trick.

Thanks!

--Anthony