Author Topic: Product Improvement Program is forceably enabled after applying a hotfix  (Read 1186 times)

davea

  • Community Member
  • Posts: 32
  • Hero Points: 4
This is a long standing irritation that, I believe, has been occurring with every version since this feature was originally introduced.

I have Product Improvement Program disabled, but every time I apply a hotfix, this feature is forcably enabled and must be manually disabled again.

Windows 64-bit

Thanks,
Dave
« Last Edit: November 20, 2017, 11:43:18 pm by davea »

mjdl

  • Senior Community Member
  • Posts: 141
  • Hero Points: 16
  • SE 23.0.2 hotfix 2 x64 Windows 10 v1903
Re: Product Improvement Program is forceably enabled after applying a hotfix
« Reply #1 on: November 22, 2017, 04:13:15 am »
Thank you for pointing this out, verified when installing the recent hotfix 11. While I'm sure SlickEdit has anonymized and minimized the information that is gathered, a hotfix really should not re-enable a user preference.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4938
  • Hero Points: 404
Re: Product Improvement Program is forceably enabled after applying a hotfix
« Reply #2 on: November 22, 2017, 04:52:48 am »
Reproduced. This is definitely a bug. We will look into this.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4938
  • Hero Points: 404
Re: Product Improvement Program is forceably enabled after applying a hotfix
« Reply #3 on: November 22, 2017, 07:46:24 pm »
This will be fixed for v22.0.1

davea

  • Community Member
  • Posts: 32
  • Hero Points: 4
I'm still seeing this issue.

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 742
  • Hero Points: 47
We thought we fixed it last time, but found another case that was not handled. We've really fixed it in v23.

Sorry about that.

++rodney