Author Topic: Minimap characters don't show Beta 2  (Read 1949 times)

Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
Minimap characters don't show Beta 2
« on: August 23, 2018, 02:49:26 pm »
For some reason capital F doesn't show up in the minimap when I'm zoomed all the way out with Lucida Console.


SlickEdit Pro 2018 (v23.0.0.3 64-bit)

License type: Beta License
License expiration: 2018-10-09 20:00:00
License file: C:\ProgramData\slickedit\23\slickedit.lic

Build Date: August 21, 2018
Emulation: CUA

OS: Windows 10 x64
OS Version: 10.00.0 
Memory: 62% Load, 5077MB/8108MB Physical, 7969MB/16300MB Page File, 4862MB/134217727MB Virtual
Shell Information: C:\WINDOWS\system32\cmd.exe /q
Screen Size: 1920 x 1050, 1920 x 1080

Project Type: Cpp
Language: .txt (Plain Text)
Encoding: Automatic
« Last Edit: August 23, 2018, 03:01:39 pm by Tim Kemp »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5282
  • Hero Points: 432
Re: Minimap characters don't show Beta 2
« Reply #1 on: August 23, 2018, 08:50:21 pm »
Weird!

Reproduced. We will look into this.

Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
Re: Minimap characters don't show Beta 2
« Reply #2 on: August 23, 2018, 09:27:17 pm »
I didn't try other characters or fonts, so I have no idea how widespread this is.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5282
  • Hero Points: 432
Re: Minimap characters don't show Beta 2
« Reply #3 on: August 24, 2018, 03:43:44 pm »
Interesting. This has to do with whether there is antialiasing for a 1 point minimap font (it's forced off right now but only for a 1 point minimap font).

Even with antialiasing on, for a proportional font like Arial, some characters (like 'i') draw nothing (0 width).

I'm wondering if there should be a special option for disabling antialiasing for small fonts or if we shouldn't bother (just use the global antialiasing setting). What do you think?

Try this. Run two instances of SlickEdit with two different config directories. Open the same sample file in both editors. Go to Window>Font and set your font to Lucida Console and manually type in 1 for the point size. Now in one of the instances turn off anti-aliasing and restart SlickEdit. Notice that the font looks a little brighter in the instance with antialiasing turned off. If you are using the Default color profile, this doesn't really seem like a useful improvement.  Try the same test using the Slate (dark background) color profile. With a dark edit window profile, the brighter font looks pretty good to my old eyes. Turning off antialiasing for larger fonts (like a two point font) doesn't appear to help.

Note: You shouldn't have to restart SlickEdit after changing antialiasing. This is fixed in beta 3.

Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
Re: Minimap characters don't show Beta 2
« Reply #4 on: August 27, 2018, 10:50:13 am »
I think having the ability to control anti-aliasing separately for small fonts is useful. With it on in the minimap window, everything turns sort of muddy and it's hard to recognize anything. On the other hand, if someone was making the minimap larger than I would with my current setup, they might want anti-aliasing to make the little characters more readable.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5282
  • Hero Points: 432
Re: Minimap characters don't show Beta 2
« Reply #5 on: August 27, 2018, 01:47:09 pm »
Are you using a light or dark background? Would you still want to turn off anti-aliasing for a 1 point font if some characters aren't drawn?

I've been running with a pre-beta 3 build with anti-aliasing turned on for the minimap and it looks ok to me. I think it looks better for the process buffer (non-color coded file). I'm using a dark background (slate).

Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
Re: Minimap characters don't show Beta 2
« Reply #6 on: August 28, 2018, 12:08:31 pm »
I'm using a light background. Changing anti-aliasing doesn't make the missing characters show for me. I had to zoom in to get them to show up. I prefer the look without anti-aliasing.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5282
  • Hero Points: 432
Re: Minimap characters don't show Beta 2
« Reply #7 on: August 28, 2018, 01:04:50 pm »
For a 1 point font AND the minimap window, the anti aliasing check box has no effect. SlickEdit forces anti-aliasing off for that case.

The only way you can test a 1 point font and anti-aliasing with beta 2 is by using Window>Font and setting the edit window font to Lucida Console and type 1 for the font size. Also, since there's a bug with the anti-aliasing check box, you'll have to restart SlickEdit to see the actuall effect (fixed in beta 3).
« Last Edit: August 28, 2018, 01:14:41 pm by Clark »

Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
Re: Minimap characters don't show Beta 2
« Reply #8 on: August 28, 2018, 02:25:52 pm »
I was restarting SlickEdit. I wasn't using the edit window to view a font size of 1. I was just looking at the minimap. Now that I'm doing what you intended, all the characters show, but even though this file has no color coding the little font has a lot of colors from the anti-aliasing.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5282
  • Hero Points: 432
Re: Minimap characters don't show Beta 2
« Reply #9 on: September 03, 2018, 01:47:04 am »
What do you think of the minimap font display beta 3? It has anti-aliasing on (same as for your other fonts).

In Beta 4 you will be able to turn anti-aliasing on/off for a specific font size using the Minimap context menu. The other anti-aliasing setting won't affect the minimap font display in beta 4.

Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
Re: Minimap characters don't show Beta 2
« Reply #10 on: September 04, 2018, 01:14:55 pm »
Anti-aliasing on the tiny characters causes them to appear in the wrong colors. Here is an example of the same hex file I posted at the top of this topic:

The missing characters now show up, but it should be all solid black lines. It's now blurry lines of black, green and red. I see similar wrong colors when I look at chroma-coded text. I don't think I'd find it nearly as useful as the mini-map without anti-aliasing.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5282
  • Hero Points: 432
Re: Minimap characters don't show Beta 2
« Reply #11 on: September 04, 2018, 07:35:46 pm »
I'm not seeing what you're seeing. Make sure you have Spell Check While Typing unchecked (Document>Spell Check While Typing).

Are using Lucida Console for the Minimap?

Please post a small sample so I can know for sure I'm looking at the same sample text.

Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
Re: Minimap characters don't show Beta 2
« Reply #12 on: September 05, 2018, 11:01:31 am »
Spell checking is turned off. I am using Lucida Console for the minimap with a size of 1. I have anti-aliasing turned on. Here is what it looks like:


I've attached that file. The document type is Plain Text.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5282
  • Hero Points: 432
Re: Minimap characters don't show Beta 2
« Reply #13 on: September 05, 2018, 09:25:37 pm »
I reproduced this. The anti-aliasing does seem to have red. With beta 4, you can try turning off anti-aliasing. You'll end up with holes of text (FFFFFF will be just blank) but there won't be any red.

With a 2 point font, there's no red anti-aliasing. I have no idea why the Windows font rendering does this for a 1 point font. I even tried turning on/off ClearType.
« Last Edit: September 06, 2018, 04:20:48 pm by Clark »