Author Topic: Menu disappear at startup then reappear after some second (40s)  (Read 651 times)

jmfrouin

  • Senior Community Member
  • Posts: 103
  • Hero Points: 2
Menu disappear at startup then reappear after some second (40s)
« on: September 10, 2018, 01:51:29 pm »
Hi,
Under GNU/Linux (Debian), when I start Slickedit the main menu appear for 1s then disappear.
After 30s it reappears.
I join 2 screenshots.
Hope this helps

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1092
  • Hero Points: 100
Re: Menu disappear at startup then reappear after some second (40s)
« Reply #1 on: September 10, 2018, 03:59:41 pm »
Which window manager do you use? And what version of debian?

Off the top of my head, I'm not sure what that could be yet.  There is some code for integrating with the menubar at the top of the screen for Unity, but that's something that should happen at startup, and not change on the fly like you're describing.

jmfrouin

  • Senior Community Member
  • Posts: 103
  • Hero Points: 2
Re: Menu disappear at startup then reappear after some second (40s)
« Reply #2 on: September 10, 2018, 04:05:43 pm »
I am under Debian Stretch and under Mate Desktop Env

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4794
  • Hero Points: 388
Re: Menu disappear at startup then reappear after some second (40s)
« Reply #3 on: September 11, 2018, 12:18:07 am »
Try setting the environment variable QT_X11_NO_NATIVE_MENUBAR to 1. It's worth a shot.

jmfrouin

  • Senior Community Member
  • Posts: 103
  • Hero Points: 2
Re: Menu disappear at startup then reappear after some second (40s)
« Reply #4 on: September 11, 2018, 05:32:17 am »
WOW This Works !!!
THANKS a lot!
Will you include some patch inside final release of VS 2018 or did I need to include this global var in my bashrc ?

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1092
  • Hero Points: 100
Re: Menu disappear at startup then reappear after some second (40s)
« Reply #5 on: September 11, 2018, 12:44:03 pm »
I think we'll be able to work around this for the next beta.  At the very least, we can try to do a more accurate restriction of the global menu integration support for the platforms we know it works with.  (Unity on Ubuntu)

Curiously I haven't reproduced it here on a Debian system with MATE, but there are some global menu applets/plugins I haven't tried yet.

jmfrouin

  • Senior Community Member
  • Posts: 103
  • Hero Points: 2
Re: Menu disappear at startup then reappear after some second (40s)
« Reply #6 on: September 11, 2018, 12:55:06 pm »
Ok .. I check, I am not under strecth sorry :) I forgot that I switch on "testing" on my laptop.
So maybe you can reproduce with Debian testing and mate.


patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1092
  • Hero Points: 100
Re: Menu disappear at startup then reappear after some second (40s)
« Reply #7 on: September 11, 2018, 01:02:14 pm »
Ahh, good to know.  I'll switch it to testing and see what happens.  Thanks.

jmfrouin

  • Senior Community Member
  • Posts: 103
  • Hero Points: 2
Re: Menu disappear at startup then reappear after some second (40s)
« Reply #8 on: September 11, 2018, 01:05:52 pm »
Debian testing / Mate 1.20.3
To be exact :)