Author Topic: Signal caught warning when GDB starts in SlickEdit  (Read 312 times)

Juan Fonseca

  • Community Member
  • Posts: 33
  • Hero Points: 1
Signal caught warning when GDB starts in SlickEdit
« on: September 24, 2018, 03:56:53 pm »
Every time I run GDB with a  program that generates a SIGUSR1, SlickEdit gives a warning (see attached).
Is as if it ignores the ~/.gdbinit file in my root directory. This does not happen when I run it from VS Code or DDD for example.
Other programs that do not generate that signal execute correctly when I lunch GDB from SlickEdit.

I am having the same problem in 2017.

I lunch GDB from the menu:
Debug->Attach Debugger->Debug Executable (GDB)...

This is the content of ~/.gdbinit

handle SIGUSR1 nostop noignore noprint
handle SIG34 nostop noignore noprint
set exec-wrapper taskset -c 0
« Last Edit: September 25, 2018, 02:20:33 pm by Juan Fonseca »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2664
  • Hero Points: 410
Re: Signal caught warning when GDB starts in SlickEdit
« Reply #1 on: September 25, 2018, 03:01:13 pm »
By default, we ignore the content of ~/.gdbinit.

We do this because we had several users who were not able to start the integrated debugging because they had things in their .gdbinit that broke everything.  Since we have no control over what people put in their .gdbinit, and GDB makes not restrictions on it either, we launch GDB with the -nx option to tell it to ignore it.

You can override this behavior by setting up a custom GDB configuration.  Debug > Debugger Options... > Configurations >
  • .  You can then point SlickEdit to the GDB executable of your choice and then specify in the arguments -x ~/.gdbinit to force it to load your settings from gdbinit.  Check the
  • Default native debugging configuration checkbox when you are done so that SlickEdit uses your GDB configuration by default when debugging local applications.


Also, FWIW, we do plan on adding a Debug Signals tool window in a future release to simplify handling and configuration of signal handling.  We realize that currently it is rather tedious in the cases where GDB's default behavior is not adequate.

Juan Fonseca

  • Community Member
  • Posts: 33
  • Hero Points: 1
Re: Signal caught warning when GDB starts in SlickEdit
« Reply #2 on: September 25, 2018, 06:15:46 pm »
Dennis,

That did it, thank you.

I tried that on Debug -> Attach Debugger -> Debug Executable (GDB), Arguments and it didn't work.

I do not find the setup tedious at all. The only problem I have is that I couldn't find how to set it up in the documentation or the forum.

Thank you again.