Author Topic: ASCII Table going into hex mode  (Read 546 times)

b

  • Senior Community Member
  • Posts: 308
  • Hero Points: 26
ASCII Table going into hex mode
« on: September 27, 2018, 08:00:18 pm »
Instead of going to the command line and typing 'man ascii', I recalled it was built into SE (Tools>ASCII Table).   However, it's kind of screwy with the SE Beta.  Looks like it's going into hex mode.

Code: [Select]
SlickEdit Pro 2018 (v23.0.0.5 64-bit)

Serial number: FE35645_BETA
License type: Beta License
License expiration: 2018-10-09 17:00:00
License file: C:\ProgramData\slickedit\23\slickedit.lic

Build Date: September 06, 2018
Emulation: Vim

OS: Windows 10 x64
OS Version: 10.00.0 
Memory: 50% Load, 8222MB/16265MB Physical, 14913MB/18697MB Page File, 6956MB/134217727MB Virtual
Shell Information: C:\WINDOWS\system32\cmd.exe /q
Screen Size: 1920 x 1040, 1200 x 1920

Project Type: Cpp
Language: . (Binary)
Encoding: Automatic

Installation Directory: C:\Program Files\SlickEdit Pro 23.0.0 Beta4\ (non-removable drive,NTFS,42297MB free)
Configuration Directory: C:\Users\bkurle\Work Folders\Documents\My SlickEdit Config\23.0.0\ (non-removable drive,NTFS,42297MB free)
Migrated from: C:\Users\bkurle\Work Folders\Documents\My SlickEdit Config\22.0.2\

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2390
  • Hero Points: 133
Re: ASCII Table going into hex mode
« Reply #1 on: September 28, 2018, 10:31:10 am »
It will restore the last way it came up.  Check to see if View>Hex is checked, and if it is uncheck it.

Tim Kemp

  • Senior Community Member
  • Posts: 536
  • Hero Points: 90
Re: ASCII Table going into hex mode
« Reply #2 on: September 28, 2018, 12:38:54 pm »
I see the same thing. It is possible to turn off the hex view, but every time I bring up the ASCII table it's in hex view.

SlickEdit Pro 2018 (v23.0.0.5 64-bit)

License type: Beta License
License expiration: 2018-10-09 20:00:00
License file: C:\ProgramData\slickedit\23\slickedit.lic

Build Date: September 06, 2018
Emulation: CUA

OS: Windows 10 x64
OS Version: 10.00.0 
Memory: 45% Load, 3713MB/8108MB Physical, 5165MB/16300MB Page File, 4751MB/134217727MB Virtual
Shell Information: C:\WINDOWS\system32\cmd.exe /q
Screen Size: 1920 x 1050, 1920 x 1080

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2390
  • Hero Points: 133
Re: ASCII Table going into hex mode
« Reply #3 on: September 28, 2018, 12:46:17 pm »
Reproduced in Beta 4.  I have to figure out if this is fixed for the current build or I had switched it out and it stayed that way.  Good catch guys!

b

  • Senior Community Member
  • Posts: 308
  • Hero Points: 26
Re: ASCII Table going into hex mode
« Reply #4 on: September 28, 2018, 04:23:45 pm »
I am curious if it has to do with the fact that the table appears to contain embedded Unicode or binary data that is forcing it into hex mode?   I noticed last night when I switched to normal view that there was a lot of unprintable (at least with the editor font set) characters.

As Tim described, changing and reopening always forces it into hex mode.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4965
  • Hero Points: 410
Re: ASCII Table going into hex mode
« Reply #5 on: September 28, 2018, 08:00:58 pm »
Fixed in beta 5