Archived Beta Discussions > SlickEdit 2018 v23 Beta Discussion

pad-star and pad-divide keys have no pad prefix

(1/3) > >>

The pad star * and pad divide / keys have an event name of just * or /.  Is that intentional or is it my keyboard?

I see slick sources looking for pad-star and pad-slash in a few places.

Works for me on Windows.
All the keys there are Pad<something>, unless numlock is on.
When numlock is on, 0-9 and . change.

The what-is command gives me PadStar but this code gives me * - on Windows with a Logitech K350 keyboard

--- Code: ---_command void testkeys() name_info(',')
   message("Press a key, ESC to exit");
   while ( 1 ) {
      _str key = get_event('N');   // refresh screen and get a key
      _str keyt = event2name(key);
      message("keyt " keyt);
      if ( keyt == "ESC" ) {

--- End code ---

If I try with a new empty config, the plus, minus and enter keys also fail to show the Pad prefix with the testkeys command.

testkeys gives mostly the same result as key binding options dialog.
Except, it returns enter instead of pad-enter, 0, 1, 3, 9 and . instead of pad-key
Curiously, it returns ENTER, but with shift it is shift-pad-enter.

Your keyboard surely could be the problem.
Have you tried windows On-Screen Keyboard? It has an option to display a numpad as well.

For me, the keyboard and OSK seem to behave the same.
event2name() I guess isn't as good as whatever is done in key bindings.


[0] Message Index

[#] Next page

Go to full version