Author Topic: Another Bug?  (Read 2735 times)

mychong

  • Community Member
  • Posts: 46
  • Hero Points: 0
Another Bug?
« on: June 12, 2007, 09:01:39 am »
There were a few occasions the clipboard contents were automatically inserted into the current working buffer/document. Does anyone have similar experience?

Could this be another SE bug???

p.s. I do not know how this happen. So I cannot provide more info on reproducing this problem.

M.Y.

SlickEdit Version 12.0.1.0

Build Date: May 21, 2007
Emulation: CUA

OS: Linux
OS Version: Fedora Core release 1 (Yarrow)
Kernel Level: 2.4.22-1.2115.nptl
Build Version: #1 Wed Oct 29 15:42:51 EST 2003
X Server Vendor: The XFree86 Project, Inc

hs2

  • Senior Community Member
  • Posts: 2733
  • Hero Points: 285
Re: Another Bug?
« Reply #1 on: June 12, 2007, 10:01:06 am »
Hard to believe that this is caused by a SE bug...
Does this happen while simply typing ?
Can you 'undo' the insertion ?
Is a SE manged clipboard entry (check w/ list-clipboards) inserted ?
Edit: Do you use add. key bindings for 'paste' (check w/ Tools>Options>Key Bindings)  ?
Do you use add. (system wide) shortcuts emulating the SE paste key binding ?
Is the build window active (maybe a 'paste' command is injected via the 'echo <binary 1><SE command>' mechanism) ?

HS2
« Last Edit: June 12, 2007, 10:10:08 am by hs2 »

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1205
  • Hero Points: 116
Re: Another Bug?
« Reply #2 on: June 12, 2007, 12:20:47 pm »
If your a mouse user, you may accidently be using the mou-paste command that is bound to middle-button (scroll wheel press).  I found myself unintentionally pasting that way, and just unbound that command.  You could try that and see if that helps.

mychong

  • Community Member
  • Posts: 46
  • Hero Points: 0
Re: Another Bug?
« Reply #3 on: June 12, 2007, 05:46:40 pm »
@HS2: Thanks for your response. (i) I can 'undo' the insertion. (ii) I did not modify any key binding. I think Lee might be right. I just recalled this problem normally happened after I used the mouse to scroll the text in the window. Probably I have asserted some pressure on the middle mouse button unintentionally. I will re-confirm this tomorrow when I return to my office.

@Lee: Thanks for the hint. I will try as suggested to unbind the paste command from the mouse button.

M.Y.