Author Topic: Sluggish performance  (Read 158 times)

dglasser

  • Community Member
  • Posts: 11
  • Hero Points: 0
Sluggish performance
« on: March 12, 2019, 03:13:47 pm »
I'm using v21.0.3.0 64-bit. I have 64GB of RAM on my Windows 10 laptop. As I'm typing Java code, there is a maddening pause after every keystroke - even the backspace key. I've tried pruning out my tag files. I've been using Slickedit for 20 years now. You would think, given the evolution in hardware during that time, it would perform better than it did in 1999, not worse.

What can I do to make this product usable again?

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2603
  • Hero Points: 396
Re: Sluggish performance
« Reply #1 on: March 12, 2019, 07:45:50 pm »
Try profiling to see where the time is being spent.  Macro > Slick-C Profiler > Begin Profiling.  Then work for a while, reproducing the delays, and then go to Macro > Slick-C Profiler > Save..., and post the result here.

Also, Java, in particular can be a strain on the Preview tool window, because of long JavaDoc comments, and very deep inheritance chains and method overloading, try closing the Preview tool window and see if performance improves.

dglasser

  • Community Member
  • Posts: 11
  • Hero Points: 0
Re: Sluggish performance
« Reply #2 on: March 14, 2019, 04:54:16 pm »
The Preview tool window is closed. The profile file is attached. I had an Iterator<Long> variable named "iterator". I started the profiler, and on a new line I typed:

iterator<space>=<space>

"<space>" above refers to a space character. When I typed the space character after the equals sign, it paused for what seemed like 3 seconds before a list of options appeared. Then I saved the profile that is attached.

I like autocomplete for class members, but I don't even want this. To have a long pause every time I type an equals sign is maddening. Oh, and BTW, In Tools > Options > Java > Auto-Complete I have the following unchecked:

Enable auto-completion
Use Syntax Expansion on space
Expand aliases on space
Space inserts longest unique prefix.

and checked is "Space always inserts space"

And it still behaves this way!

My space key is bound (apparently by default) to the java_space command. Should I just unbind that, and if so, how?
« Last Edit: March 14, 2019, 04:56:41 pm by dglasser »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2603
  • Hero Points: 396
Re: Sluggish performance
« Reply #3 on: March 14, 2019, 10:12:47 pm »
Try this:

Document > [lang] Options... > Auto-Complete > List Symbols > uncheck Auto-list compatible values

You may also want to uncheck:

Document > [lang] Options... > Context Tagging > Parameter Information > Auto-List compatible parameters

dglasser

  • Community Member
  • Posts: 11
  • Hero Points: 0
Re: Sluggish performance
« Reply #4 on: March 15, 2019, 12:23:39 pm »
Try this:

Document > [lang] Options... > Auto-Complete > List Symbols > uncheck Auto-list compatible values

You may also want to uncheck:

Document > [lang] Options... > Context Tagging > Parameter Information > Auto-List compatible parameters

I unchecked both of those, and it works beautifully now, even with autocomplete re-enabled. Thanks very much!