Author Topic: Erasing a tab gives a space behind cursor  (Read 144 times)

guth

  • Community Member
  • Posts: 79
  • Hero Points: 7
Erasing a tab gives a space behind cursor
« on: April 01, 2019, 06:23:06 am »
If having the following in a C++ file (using GNU Emacs key bindings) where arrow means tab, dot (.) means space, and | means cursor

->->|

Now hitting back space one time yields

->...|.

Hitting backspace three times yields

->|.

Now hitting backspace again yields

...|..

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2275
  • Hero Points: 128
Re: Erasing a tab gives a space behind cursor
« Reply #1 on: April 01, 2019, 09:57:27 am »
Go to Macro>Set Macro Variable and set the variable "def_hack_tabs" to 0.  This is on a dialog somewhere but I'm not sure where and I'm on my first cup of coffee  ;)

guth

  • Community Member
  • Posts: 79
  • Hero Points: 7
Re: Erasing a tab gives a space behind cursor
« Reply #2 on: April 01, 2019, 10:16:37 am »
Great! That seems to work.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2275
  • Hero Points: 128
Re: Erasing a tab gives a space behind cursor
« Reply #3 on: April 01, 2019, 10:19:33 am »
If memory serves, this was a very old Emacs behavior.

mwb1100

  • Senior Community Member
  • Posts: 142
  • Hero Points: 13
Re: Erasing a tab gives a space behind cursor
« Reply #4 on: April 02, 2019, 06:41:54 pm »
That is one of the weirdest "it's a feature, not a bug" things I've ever heard.

How does having to support a setting like that not drive you crazy?