Author Topic: SE 23.0.1.2 XHTML wrong document mode  (Read 235 times)

Marcel

  • Senior Community Member
  • Posts: 205
  • Hero Points: 25
SE 23.0.1.2 XHTML wrong document mode
« on: April 15, 2019, 03:14:39 pm »
My .xhml files are being classified as XML (Document -> Mode). I have separate configurations and beautifier formats for XHTML and XML and need SE to pick up the XHTML type for that extension.  I have worked around this by explicitly setting the document mode for individual files, but that is impractical in the long run.  How can I configure SE to make the correct classification?

mjdl

  • Senior Community Member
  • Posts: 139
  • Hero Points: 16
  • SE 23.0.2 hotfix 2 x64 Windows 10 v1903
Re: SE 23.0.1.2 XHTML wrong document mode
« Reply #1 on: April 15, 2019, 04:33:55 pm »
Haven't run into this problem before, but (at the risk of repeating what you have probably already done) I'd start by verifying that the file extension .xhtml only appears in the "File Extensions" list of the XHTML language type at Options-->Languages-->Web Authoring Languages-->XHTML and does not appear in the file extension list of the XML language type. Also, ensure that the entry for the ".xhtml" file extension in Options-->Languages-->File Extension Manager references the XHTML language type.

Marcel

  • Senior Community Member
  • Posts: 205
  • Hero Points: 25
Re: SE 23.0.1.2 XHTML wrong document mode
« Reply #2 on: April 15, 2019, 06:12:25 pm »
Thanks for the help. Out of the box, the .xhtml extension is indeed associated with XML. Changed it to XHTML.