Author Topic: Build tool window not scrolling when also sent to editor window  (Read 389 times)

rowbearto

  • Senior Community Member
  • Posts: 1409
  • Hero Points: 109
Occurs with SE 23.0.1.2 hotfix 6, Linux x64, CentOS 7.2

This issue started happening recently for me, it was fine before, so I think it got introduced with recent hotfix.

To reproduce:

1) Clean config, then apply hotfix 6
2) Load attached workspace
3) IMPORTANT: In the Build tool Window, right click and check "Send Compile Output to Editor Window"
4) Make "Debug" the active configuration
5) Build->Build

Notice that the build tool window does not keep scrolling (but the editor window does).
« Last Edit: May 25, 2019, 10:12:11 pm by rowbearto »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4814
  • Hero Points: 391
Re: Build tool window not scrolling when also sent to editor window
« Reply #1 on: May 28, 2019, 10:12:04 pm »
As far as I can tell, this has never worked. I tried v22.0.2, v23.00, v23.0.1. None scroll build output with your example. Not sure if there is a natural fix for this without looking into this first. Once you turn off "Send Compile Output to Editor Window", then scrolling output always works in the Build tool window.

I have "Send Compile Output to Editor Window" On but I never use the Build tool window.

I'll have a look and see whats up here.

rowbearto

  • Senior Community Member
  • Posts: 1409
  • Hero Points: 109
Re: Build tool window not scrolling when also sent to editor window
« Reply #2 on: May 29, 2019, 12:57:37 am »
Thanks for having a look Clark.

Perhaps the reason why I never saw it before was that I didn't have the particular trigger to cause this issue? It seems to happen every time now that I run pylint in a "Build" window in a Python project - not sure I did that before.

If I send the compile output to the editor window while I also have it going to the Build window, it would be nice if the process buffer editor window did not become the active window when I do "Build", and just the Build tool window becomes active. I'd rather have the editor buffer that I was on stay there when I do a build, I can always switch to the full process buffer editor window when needed.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4814
  • Hero Points: 391
Re: Build tool window not scrolling when also sent to editor window
« Reply #3 on: May 29, 2019, 01:54:01 am »
Turn off the "Send" feature. Then try the following "e +b .process" on the SlickEdit command line. This will work as long the Build tool window is displayed.

rowbearto

  • Senior Community Member
  • Posts: 1409
  • Hero Points: 109
Re: Build tool window not scrolling when also sent to editor window
« Reply #4 on: May 29, 2019, 02:02:16 am »
Thanks Clark.

e +b .process is displaying the .process buffer and it doesn't become active when I do a build.

However if I do "next_error", it would be nice if the big .process editor window would move to the next error (even if the file with error is active and .process does not go active, would be nice if .process editor window would go to the line with the error message).

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4814
  • Hero Points: 391
Re: Build tool window not scrolling when also sent to editor window
« Reply #5 on: May 29, 2019, 02:05:52 am »
The only work around I can think of is to wrapper next-error with temporarily turning on the "Send" feature. However, I don't know what affect that will have on the Build window.