Author Topic: What is this (gibberish) hover window text when mouse cursor is on a number?  (Read 6838 times)

pieterc

  • Community Member
  • Posts: 31
  • Hero Points: 3
Hi everyone,

Apologies for the lame subject heading, but I don't know what the right wording is to describe and google for what I'm seeing.

See attached screenshot. When the mouse cursor is over a number, a hover window pops up to show decimal, hex, octal, binary versions of the number. Fair enough, that's helpful, but what why is there extra distracting HTML text referring to "vslick://bbpaste.svg@14"? How do I fix it?

Thanks in advance,
Pieter

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1094
  • Hero Points: 100
That sounds like a bug that was fixed in one of the recent hot-fixes.  Applying the latest 23.0.2 hotfix from https://customer.slickedit.com/support/product-updates/hotfixes should take care of that.

pieterc

  • Community Member
  • Posts: 31
  • Hero Points: 3
Hi Patrick,

Yes that did the trick thanks! Sorry, I should have thought of loading the latest hot fix first  :-[

Best regards,
Pieter

garyshall

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Is there a way to turn OFF this pop-up box?  I cannot find one!

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1094
  • Hero Points: 100
There's a per-language setting for that.  If you've got a source file up, go to Documents -> [Language] Options..., and in the dialog that pops up, go to Context Tagging.  Under "Preview, Highlighting and Completion" uncheck "Show info for symbol under mouse".

garyshall

  • New Community Member
  • Posts: 2
  • Hero Points: 0
I have gone to documents, and [language] options and I cannot find the context editing you mentioned.  I am on SlickEdit Standard 2018 (v23.0.2.0 64-bit).  Do I need the Pro Version, or to upgrade in another way?

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1094
  • Hero Points: 100
Interesting.  That seems to be a bug.  That setting I posted controls code help popups for features related to Context Tagging, but the popup for hovering over numbers is really separate from Context Tagging, and should  have its own setting.

We're going to do something for the next hotfix to take care of this.  I'll post again to let you know how to disable that once we have a hotfix ready.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1094
  • Hero Points: 100
Ok, the fix for this will be in cumulative hotfix #4.  Once that comes out and you apply it, you can go to Tools -> Options -> Appearance -> General, and turn off the "Show number base popups" setting. 

sigmund

  • Community Member
  • Posts: 54
  • Hero Points: 6
That is great to hear, I found this feature to be more annoying than useful.  Especially since the popup goes in front of other dialogs (see attachment).  It would make more sense if the number popup only showed up when holding down a modifier key (e.g. Ctrl).