Author Topic: beta2: Error closing tags database  (Read 1702 times)

rowbearto

  • Senior Community Member
  • Posts: 2106
  • Hero Points: 127
beta2: Error closing tags database
« on: August 09, 2019, 03:33:53 pm »
I have a workspace with 7 projects. I just closed one project and then inserted a new, but similar project (basically changed from an SE project of openssl 0.98 to 1.02), then I got the error:

"Error closing tags database mytagfile.vtg. File Not found."

I pressed OK and it is doing a background tag now.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3528
  • Hero Points: 471
Re: beta2: Error closing tags database
« Reply #1 on: August 09, 2019, 06:11:37 pm »
Were these projects configured to create project-specific tag files ?

Is the tag database you get the message about the one associated with the project you closed, or the project you added ?

What do you exactly mean by closing the project?  Did you close the workspace?  Or did you remove the project from the workspace?

Could you zip up the workspace file and the relevant project files so that I can try to track down this problem?

rowbearto

  • Senior Community Member
  • Posts: 2106
  • Hero Points: 127
Re: beta2: Error closing tags database
« Reply #2 on: August 09, 2019, 06:24:49 pm »
Quote
Were these projects configured to create project-specific tag files ?
No

Quote
Is the tag database you get the message about the one associated with the project you closed, or the project you added ?
It was the tag database for the entire workspace.

Quote
What do you exactly mean by closing the project?  Did you close the workspace?  Or did you remove the project from the workspace?
I removed the project from the workspace. In the "Projects" tab I single clicked the project, then pressed the delete key.

Quote
Could you zip up the workspace file and the relevant project files so that I can try to track down this problem?
Look for "slickopt.tar.gz" on support. The workspace file is "devtest.vpw". I originally had openssl098.vpj as part of the workspace. Removed that and then inserted openssl102.vpj into the workspace. Upon the insert I got the error. I since removed openssl102.vpj from the workspace and did project->new and created a new project to insert into the workspace, the openssl_1_1_1c.vpj, but that did not repeat the issue.

This only happened to me one time and haven't seen it since - although I have not tried this again.

rowbearto

  • Senior Community Member
  • Posts: 2106
  • Hero Points: 127
Re: beta2: Error closing tags database
« Reply #3 on: August 13, 2019, 06:25:55 pm »
I got this error a 2nd time today. This time I had a workspace with 1 project then went to insert and existing project into the workspace. The insert triggered the error.

I uploaded to support - community_tools.tar.gz to support

Originally had just "community_tools.vpj" in the workspace, then I inserted v1830auto.vpj into the workspace and got an error about closing the community_tools.vtg workspace. I do not have per-project tagging enabled.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3528
  • Hero Points: 471
Re: beta2: Error closing tags database
« Reply #4 on: September 10, 2019, 05:19:33 pm »
Reproduced.  Will put in a fix for the next build.