Author Topic: ISPF Mode Line Commands  (Read 279 times)

dashley

  • Community Member
  • Posts: 13
  • Hero Points: 0
ISPF Mode Line Commands
« on: August 12, 2019, 05:29:54 pm »
Line commands in ISPF mode (commands entered in the line number prefix area) are STILL broken! The c, cc, m, and mm commands still do not work. No line(s) are copied or moved in either the before or after area indicated by the a or b line commands. Please fix this!!!!! It has been broken for the last two versions of SE and I am tired of waiting for a fix. I have reported this before to no avail. ISPF may not be popular but it deserves to be keep up.

Thanks,
W. David Ashley

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2713
  • Hero Points: 413
Re: ISPF Mode Line Commands
« Reply #1 on: August 12, 2019, 07:36:11 pm »
Could you give a complete sample file with step-by-step instructions?  I tested the commands and they all worked correctly.

Also, verify if this still happens to you if you are working in a default configuration.  You can start the editor with a default configuration by starting the editor with the arguments:
     vs +new -sc [some temporary directory]

Finally, what language mode are you seeing this problem in?

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1275
  • Hero Points: 126
Re: ISPF Mode Line Commands
« Reply #2 on: August 12, 2019, 07:46:00 pm »
I just checked ISPF emulation in both v23 and v24 Beta, c and cc line commands were working the way I expected it them to work or at least how I remembered it worked.  In as much detail as you can give, where is it not working for you?  Like, keystroke by keystroke detail, what are the expected steps and results.

dashley

  • Community Member
  • Posts: 13
  • Hero Points: 0
Re: ISPF Mode Line Commands
« Reply #3 on: August 12, 2019, 08:02:33 pm »
It does not work for me. See the attached screen captures. The first is just before I press cntl-Enter and the second is after pressing the key. The After line command disappears and leaves the CC commands on the screen with no copy resulting, just an added new line.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1275
  • Hero Points: 126
Re: ISPF Mode Line Commands
« Reply #4 on: August 12, 2019, 08:17:27 pm »
Can you double-check your default keybinding for Ctrl+Enter under Tools > Options > Keyboard and Mouse > Key Bindings?  It should be bound to ispf-do-lc command by default.

dashley

  • Community Member
  • Posts: 13
  • Hero Points: 0
Re: ISPF Mode Line Commands
« Reply #5 on: August 12, 2019, 08:23:54 pm »
As you can see in the attached screen shot, all is as it should be.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1275
  • Hero Points: 126
Re: ISPF Mode Line Commands
« Reply #6 on: August 12, 2019, 08:39:41 pm »
Hmm, I don't see any obvious issues using a clean install with default options.  Could you post your user.cfg.xml file from your SlickEdit options directory, could be a setting in there that we are overlooking that is causing the unexpected result.

dashley

  • Community Member
  • Posts: 13
  • Hero Points: 0
Re: ISPF Mode Line Commands
« Reply #7 on: August 12, 2019, 08:51:19 pm »
Attached is the file. Thanks for your time on this.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1275
  • Hero Points: 126
Re: ISPF Mode Line Commands
« Reply #8 on: August 12, 2019, 09:50:30 pm »
Thanks, that is what I needed to reproduce.  Does appear to be an issue with enabling the XEDIT line commands option.  It is confusing the A(fter) option for the XEDIT A(dd) line option.  B(efore) option should be okay, at least it has been in the testing.   I have gone back several years of versions and see the same issue, I can't say when this may have ever worked correctly.  I will have to go through source control history to find that out.   I will file a defect to see if this can be hot fixed or work around for the case of copy and move line commands.  I would recommend disable the XEDIT option for now, that is if you can do without any of the other XEDIT translated commands.

dashley

  • Community Member
  • Posts: 13
  • Hero Points: 0
Re: ISPF Mode Line Commands
« Reply #9 on: August 12, 2019, 10:02:53 pm »
Thank you so much for your help with this issue. It has been bugging me for a while now as you can see. I very much appreciate your help resolving this issue. I look forward to a fix for this but at least now I have a work-around.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1275
  • Hero Points: 126
Re: ISPF Mode Line Commands
« Reply #10 on: August 19, 2019, 12:59:22 pm »
Following up after investigating this, it is working as designed.  The correct usage for XEDIT is to use 'F' or 'P' with Copy/Move line command rather than 'A' or 'B'.  There is no defect here.