Author Topic: Build window shows odd characters when building if you have Clink installed  (Read 2059 times)

macjohnmcc

  • Community Member
  • Posts: 59
  • Hero Points: 1
CLINK CLINK C:\dev\Entrap\EntrapPointProduct\Module>

Clink can be had here:
https://mridgers.github.io/clink/

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1299
  • Hero Points: 130
My guess is that it is using UTF-8 encoded output, which is not the default for Build window for SlickEdit on Windows.  There is a macro variable, you can enable UTF-8 which you'll have to enable using Macro > Set Macro Variable..., and set the variable def_build_allow_utf8_2, and change the value to non-zero.  Then restart SlickEdit and test to see if the output looks correct.

macjohnmcc

  • Community Member
  • Posts: 59
  • Hero Points: 1
Where do I learn about all of these macros I can set?

BTW when I changed that macro to 1 and restarted VS the output is even crazier
C<BS>L<BS>I<BS>N<BS>K<BS> <BS>C<BS>L<BS>I<BS>N<BS>K<BS> <BS>C:\dev\Entrap\EntrapCli>
« Last Edit: August 16, 2019, 06:25:43 pm by macjohnmcc »

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1299
  • Hero Points: 130
Most macro variables are typically exposed in Options with meaningful text and help to explain there purpose.  Not all of them though, some are just there in case of unusual or out of the ordinary situations.  This one didn't seem to fix the issue though, so you can set it back to zero.  Those appear to be escaped characters, there is a new setting that was designed to handle escapes in Beta 2 under Tools > Options > Appearance > General,  and toggle Process recognized xterm color output in build window, to see if that changes anything.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5462
  • Hero Points: 444
The new xterm escape processing code doesn't do anything with a backspace character (character code 8 ). Looks like this tool is outputting cursor movement terminal escape sequences not supported by SlickEdit. This is not a new limitation. I'll see if we can add support for a backspace character without messing anything up. My first attempt is looking good so far.
« Last Edit: August 17, 2019, 12:10:27 am by Clark »