Author Topic: .process buffer stuck in wrong mode  (Read 1000 times)

link

  • Community Member
  • Posts: 53
  • Hero Points: 3
.process buffer stuck in wrong mode
« on: August 13, 2019, 03:02:21 am »
I accidentally changed the Document mode for the build buffer (.process) to something other than Process, and now I can't switch it back.  Process doesn't appear when I go to Document -> Select Mode, and setting it to automatic does nothing.  I can't click on error messages now to switch to the appropriate buffer now that its the wrong mode.  How can I fix this?  SlickEdit Pro 2018 (v23.0.0.10 64-bit Windows)

Graeme

  • Senior Community Member
  • Posts: 2336
  • Hero Points: 307
Re: .process buffer stuck in wrong mode
« Reply #1 on: August 13, 2019, 05:50:51 am »
On the command line you can type
select-mode process

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2357
  • Hero Points: 131
Re: .process buffer stuck in wrong mode
« Reply #2 on: August 13, 2019, 11:31:24 am »
You can also go to Document>Select mode.

link

  • Community Member
  • Posts: 53
  • Hero Points: 3
Re: .process buffer stuck in wrong mode
« Reply #3 on: August 13, 2019, 06:51:28 pm »
As I mentioned above, Process does not appear in the list when you got to Document -> Select Mode.  But Graeme's command fixed it.  Thanks so much!

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2357
  • Hero Points: 131
Re: .process buffer stuck in wrong mode
« Reply #4 on: August 14, 2019, 01:28:17 pm »
As I mentioned above, Process does not appear in the list when you got to Document -> Select Mode.  But Graeme's command fixed it.  Thanks so much!
Sorry, I overlooked that.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2739
  • Hero Points: 419
Re: .process buffer stuck in wrong mode
« Reply #5 on: August 14, 2019, 03:21:53 pm »
Omitting "Process" from that menu is intentional.  It isn't exactly the sort of mode you would want to switch any normal file too.  Not a problem except for this rare case where someone, somehow, changes the mode of the build window.  I am going to check in a tweak to disable select-mode from the menu for the process buffer (and a few other SlickEdit specific modes that should not be messed with).