Author Topic: Odd behavior loading file from command line VS2019 B2 Windows X64  (Read 1882 times)

macjohnmcc

  • Community Member
  • Posts: 59
  • Hero Points: 1
If I specify a file to open on the command line without VS2019 (B2) already running VS starts up and shows a window with the name of the file in the title bar but all in lower case not matching the case of the file name on disk. The file does not load. If VS2019 is already running and I specify the same command line to load the file it loads promptly and the contents are shown with the title bar showing the file name with the matching case of the file on disk.

VS2017 always loads the file specified on the command line regardless of if it is already running or not.

I tried it with multiple different files all with the same result.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1299
  • Hero Points: 130
Re: Odd behavior loading file from command line VS2019 B2 Windows X64
« Reply #1 on: August 16, 2019, 08:24:29 pm »
Anything special about the file?  Is it on a network file system, or mapped to a network share?  Need more info on being able to reproduce this, I haven't seen any issue so far.

macjohnmcc

  • Community Member
  • Posts: 59
  • Hero Points: 1
Re: Odd behavior loading file from command line VS2019 B2 Windows X64
« Reply #2 on: August 16, 2019, 09:20:15 pm »
The files are just on the local NTFS formatted partition. If there is some kind of debug logging I can enable to help let me know. The behavior is consistent. I am working from a command prompt running as administrator if that makes a difference. Slickedit 2017 works fine it's just 2019 that has the issue.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5012
  • Hero Points: 417
Re: Odd behavior loading file from command line VS2019 B2 Windows X64
« Reply #3 on: August 16, 2019, 11:39:09 pm »
Did you configure your NTFS file system to be case sensitive? I don't even know if that's possible but I had to ask.

macjohnmcc

  • Community Member
  • Posts: 59
  • Hero Points: 1
Re: Odd behavior loading file from command line VS2019 B2 Windows X64
« Reply #4 on: September 05, 2019, 06:09:53 pm »
I still see this behavior with Beta 3.

I start the process like this:
From a command prompt running as administrator
c:\slickedit2019\win\vs.exe <myfile>

If slickedit is not running it starts and creates a window with the title of the file "<myfile>" but does not load the contents of the file.

If slickedit is running it loads "<myfile>" properly.

Reproduces 100% of the time. If I run slickedit 2018 it works 100% of the time regardless of it it was already running or not. From the same command prompt on the same volume of the same drive. NTFS nothing special just Windows 10 X64.

As it stands if 2019 ships with this bug it won't be usable by me and I'll have to stick with 2018.
There are no warnings/errors showing and it doesn't matter what type of file I load.
From the same command prompt I can also edit this file with virtually all the other editors on my computer from vim, notepad, notepad++, sublime text, visual studio etc.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5012
  • Hero Points: 417
Re: Odd behavior loading file from command line VS2019 B2 Windows X64
« Reply #5 on: September 06, 2019, 12:59:06 pm »
We have reproduced this. The trick is not to specify a path on the file. v24 must be messing up the current directory.
« Last Edit: September 06, 2019, 01:15:45 pm by Clark »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5012
  • Hero Points: 417
Re: Odd behavior loading file from command line VS2019 B2 Windows X64
« Reply #6 on: September 06, 2019, 04:23:05 pm »
Fixed for beta 4

macjohnmcc

  • Community Member
  • Posts: 59
  • Hero Points: 1
Re: Odd behavior loading file from command line VS2019 B2 Windows X64
« Reply #7 on: September 06, 2019, 05:50:50 pm »
Thank you. I will switch to using VS2019 when beta 4 comes out.