Author Topic: Confused bash. SE adds "#" characters to each new cmd line, but can't be removed  (Read 149 times)

mtaylor_emeraldcave_net

  • Community Member
  • Posts: 12
  • Hero Points: 1
This pertains to the beta.  Often when I am using the build shell to type commands, it will get stuck in a
mode where every time I hit enter it pre-types a # symbol on the prompt line and no commands work. 
I frequently exit the shell and re-open it to recover.  Sometimes select-all + delete can help. 
It's very strange because backspace may erase the character but the commands still fail..  The most effective way to recover that I have found is to select all and hit delete a few times and then blindly type exit<enter> until I can create a new shell.  The new shell is always in a working state at first.

I'm still trying to narrow down what triggers the condition, but it's slowing me down.

SlickEdit Pro 2019 (v24.0.0.3 64-bit)
License type: Beta License
License expiration: 2019-10-27 17:00:00
License file: /opt/slickedit-pro2019beta2/bin/slickedit.lic

Build Date: August 7, 2019
Emulation: CUA

OS: Linux
OS Version: Ubuntu 19.04
Kernel Level: 5.0.0-27-generic
Build Version: #28-Ubuntu SMP Tue Aug 20 19:53:07 UTC 2019
Processor Architecture: x86_64

X Server Vendor: The X.Org Foundation
Memory: 68% Load, 5161MB/7518MB Virtual
Shell Information: /opt/slickedit-pro2019beta2/bin/secsh -i
Screen Size: 3840 x 2160

Project Type: Cpp
Language: .mk (Makefile)
Encoding: Automatic

Installation Directory: /opt/slickedit-pro2019beta2/
Configuration Directory: /home/********/.slickedit/24.0.0/
Migrated from: /home/*********/.slickedit/23.0.0/

2019-09-08T23:12:09+0000 71859

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2743
  • Hero Points: 419
From the Build Window, right click and select "Send Compile Output to Edit Window", then go to the top Menu > Documents > Select Mode...  The current mode should show up as Process.  There should be a menu item named something like "Process Options..."  If not, then you have changed the document mode of the Process buffer and this explains the odd behavior.  From the SlickEdit command line, type the command "select-mode Process" to correct it.

If not, can you reproduce this issue from a default configuration ?

mtaylor_emeraldcave_net

  • Community Member
  • Posts: 12
  • Hero Points: 1
Yes, I see it's set to Process.  I haven't figured out how to reliably reproduce it but I'm working on it.  Thanks.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2743
  • Hero Points: 419
Have you modified the color coding for the the Process mode?  Unless you are running as Root, what you are seeing sounds like automatic comment extension.

mtaylor_emeraldcave_net

  • Community Member
  • Posts: 12
  • Hero Points: 1
I probably adjusted global color settings, but not specifically the Process section under "SlickEdit Languages".  When I open up Process -> Color Coding it shows Profile: (none).  "Automatically close block comments (affects all languages) is checked.  Which includes "split line comments".  Sounds like "Split strings on Enter", but since I can't reproduce it reliably it's hard to know.  If it were comments, how would I start slickedit thinking I was in a block comment using # characters?  Block comment format isn't defined for Process and the "styles" in the global settings don't include anything like #'s.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4796
  • Hero Points: 388
If you have a color coding profile set for Process (Tools>Languages>SlickEdit Languages>Process>Color Coding), post your user.cfg.xml here. The default setting is (None) which means there isn't a color coding profile set.