Author Topic: Auto-complete settings for SlickEdit Pro 2018 (v23.0.2.0 64-bit)  (Read 248 times)

sooth

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Auto-complete settings for SlickEdit Pro 2018 (v23.0.2.0 64-bit)
« on: September 21, 2019, 10:45:28 am »
Trying to use the auto-complete feature for C in SlickEdit Pro 2018 and I can't seem to get it to run.

Example:
struct my_struct
{
int fruits;
int friends;
int ratings;
};

void sample_func()
{
struct my_struct local_struct;

}

I type "l" in sample_func and no list of symbols show up showing "local_struct". I have to type the whole variable in.

Then, when I type "local_struct.", a list of symbols appear but they disappear when I type the next letter "f" instead of filtering out to only "fruits" and "friends".

I've tried changing all the settings in "Completion choice" and "Preserve identifier to the right of the cursor" but no luck. Enable auto-completion is turned on for everything. Any ideas if I've missed something?

Running on Ubuntu 18.04.


Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4938
  • Hero Points: 404
Re: Auto-complete settings for SlickEdit Pro 2018 (v23.0.2.0 64-bit)
« Reply #1 on: September 21, 2019, 01:28:06 pm »
Can't reproduce so far.

Try a default config:  vs +new -sc <temp-config-directory>

That might help narrow things down.
« Last Edit: September 21, 2019, 05:14:52 pm by Clark »

Graeme

  • Senior Community Member
  • Posts: 2366
  • Hero Points: 313
Re: Auto-complete settings for SlickEdit Pro 2018 (v23.0.2.0 64-bit)
« Reply #2 on: September 21, 2019, 01:56:46 pm »
How long have you been using slickedit for?
Do you have the pro version or the standard version? [oops, I see you have the pro version]
Has autocomplete ever worked for you.  If no symbols pop up, try running the command "autocomplete"  - default binding is ctrl-space I think.
If you have a typo higher up in the code, it can sometimes throw slickedit syntax parsing off completely.