Author Topic: SHIFT+F10 Not Working in SEPro v24.0.0.7 Win 64-bit [SOLVED]  (Read 1267 times)

Allan

  • Community Member
  • Posts: 26
  • Hero Points: 1
SHIFT+F10 Not Working in SEPro v24.0.0.7 Win 64-bit [SOLVED]
« on: October 02, 2019, 07:03:47 pm »
I installed SEPro v24.0.0.7 this AM and now when I try to compile a C++ program by pressing Shift+F10 nothing happens.  My project is setup to use the GCC-9.2.0-x86_64-w64-mingw32 compiler. If I click on the menu item Compile (Shift+F10), my program compiles.  If I press Ctrl+M, SE builds my program and if I press Ctrl+F5 my program runs.  So, it appears that only Shift+F10 isn't working.

Anyone else having this problem?  Any suggestions on how to fix this?
« Last Edit: October 04, 2019, 02:46:35 am by Allan »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6128
  • Hero Points: 470
Re: SHIFT+F10 Not Working in SEPro v24.0.0.7 Win 64-bit
« Reply #1 on: October 02, 2019, 07:16:30 pm »
Weird. Seems to be a slight difference with Qt5. SlickEdit only uses Qt5 for 64-bit windows (not 32-bit windows or other platforms). What's odd is that F10, Ctrl+F10, Alt+F10 all work.

I'll keep you posted.


Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6128
  • Hero Points: 470
Re: SHIFT+F10 Not Working in SEPro v24.0.0.7 Win 64-bit
« Reply #2 on: October 03, 2019, 06:59:34 pm »
Download 24.0.0.8. Shift+F10 will now work in the editor for 64-bit Windows in v24.0.0.8

Allan

  • Community Member
  • Posts: 26
  • Hero Points: 1
Re: SHIFT+F10 Not Working in SEPro v24.0.0.7 Win 64-bit
« Reply #3 on: October 04, 2019, 01:23:13 am »
I downloaded 24.0.0.8, but it won't install. When I try to install it, I get the following pop-up message:

"Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel."

I tried right-clicking on the 24.0.0.8 file and selecting Repair, but I got the following pop-up message: "This action is only valid for products that are currently installed."

It appears that I'm caught in a Catch-22.  Do I need to uninstall 24.0.0.7? If so, will I lose my configuration settings?


Allan

  • Community Member
  • Posts: 26
  • Hero Points: 1
Re: SHIFT+F10 Not Working in SEPro v24.0.0.7 Win 64-bit
« Reply #4 on: October 04, 2019, 02:45:36 am »
I backed up my c:\users\<username>\Documents\My Slickedit Config\24.0.0.0 folder and uninstalled 24.0.0.7.  The uninstall didn't touch the 24.0.0.0 config folder.  I then installed 24.0.0.8 and Shift+F10 is now working.  Thanks Clark!

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6128
  • Hero Points: 470
Re: SHIFT+F10 Not Working in SEPro v24.0.0.7 Win 64-bit [SOLVED]
« Reply #5 on: October 04, 2019, 03:31:19 am »
You do have to uninstall the previous sub minor version (24.0.0.7 vs 24.0.0.8 ). I’m pretty sure this is a limitation of our guid generation for the installer. If it were 24.0.1.x, then you wouldn’t have to uninstall 24.0.0.x
« Last Edit: October 04, 2019, 12:26:37 pm by Clark »