Author Topic: Slick is hung on startup- how to recover?  (Read 1907 times)

cappy2112

  • Community Member
  • Posts: 91
  • Hero Points: 0
Slick is hung on startup- how to recover?
« on: June 20, 2007, 08:47:11 pm »
I'm having a problem with Slick- I thought it was with a macro I was editing- but I've renamed that macro so it doesn't get opened in the editor on startup.

It was building a Tag file, started taking too long. I Clicked on the Rex X in the Building Tag File message box, but it did not cancel the Build Tags process. Ever since then, Slick hangs after launching it.
If Build Tags cannot be cancelled or cancelled safely, then that Red X should not be there.

I had to use Process manager to shut it down, have rebooted, but the problem Still persists.

At this point, the only thing I can think of is uninstall-reinstall

I'm using 12.01 on XP SP2


« Last Edit: June 20, 2007, 08:53:27 pm by cappy2112 »

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Slick is hung on startup- how to recover?
« Reply #1 on: June 20, 2007, 09:18:05 pm »
Wow! You're having a run of bad luck today. Before uninstall/reinstall, try deleting the contents of your config directory. If v12.0.1 is your first version of SlickEdit, you can delete the 12.0.1 directory. If you have previous versions, delete the contents of that directory but leave the directory in place. This will create a default configuration which is one of the key ways we try to troubleshoot problems. You should back up your config directory first if you want to restore it later. 

This may also solve the problem you reported about the workspace not being restored. By default, SlickEdit does open the last Workspace you had open. Be sure you have write access to your config directory, which should be in My Documents/My SlickEdit Config/12.0.1.

--Scott