Author Topic: Am I doing something wrong or is SlickEdit literally the worst for Haskell?  (Read 172 times)

shootgun1

  • Community Member
  • Posts: 11
  • Hero Points: 0
Hi Guys,

I have been a very happy SE user for 12 years or so, mostly doing C/C++. I am trying to get back on my Haskell skills for new project after many years of break . I upgraded my Slickedit license to 2019 and downloaded the latest version. So far, I am extremely unhappy with my experience with SE2019 for Haskell. I wanted to ask if I am doing something wrong.

Below are list of my problems:

* [General] In Linux, the options window automatically resizes itself while you are going through options. Sometimes this resizing moves buttons (OK, Cancel, etc) outside of the screen, so you can never click them. The resize button is missing from the top left.

* The color coding is extremely weak. I cant get Slickedit to do color coding no matter what. (The only color coding that works are the comments and some keywords)

* Auto complete is not working as intended, it is not auto completing the symbols, but rather any text. (typing a function parameter from inside a function just shows bunch of texts that appeared before)

* The preview window is not working. I define function test1, then I call test1 from test2. When I move the cursor over test1 inside test2, the preview window shows nothing for test1

* it has no help/preview/etc for standard Haskell functions. Autocomplete also is not working for standard Haskell functions.

* The cursor automatically positions itself to keep typing under the latest indent (function, loop, etc). I move the cursor manually to the beginning of the line to start defining a new function. If I press enter because I want to add couple more lines of space from the previous function, then the cursor gets back to the middle of the screen. (I have an habit of pressing enter to add lines). I have to wrestle the cursor each time I want to define a new function.

As it is now, VS2019 for Haskell seems like barely an upgrade from notepad from 1998. Am I doing something wrong?

The file I am editing has .hs extension and I think SE2019 recognizes it as Haskell file no problem.
« Last Edit: October 11, 2019, 07:53:16 pm by shootgun1 »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2791
  • Hero Points: 422
Our Haskell support is pretty limited.  Not a high-demand (Tier 1) language. 

Our Auto-complete, Defs tab, all the tagging related support only has a proc-search (haskell_proc_search).  Generally, these are designed to just pick up function names.

Do you have any specific examples of the color coding being incorrect for Haskell ?

If you change your Dialog font to a smaller font, that should help with some of the options dialog growth problems.  Unfortunately, we do have some options pages that simply are large.  I don't know what kind of a display you have, but we recommend at least an 1280x768 resolution.

shootgun1

  • Community Member
  • Posts: 11
  • Hero Points: 0
As you can see in the attachment, my screen resolution is 1600x1200.
Thanks.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4896
  • Hero Points: 399
Trying setting your Dialog font to something smaller. That should help a lot. I tried it and it shrunk my options dialog by a ton.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2791
  • Hero Points: 422
Your screenshot says 1920x1080.  Either way, those fonts still look large, do you have font scaling or fractional scaling enabled on your display ?

https://wiki.archlinux.org/index.php/HiDPI#GNOME
« Last Edit: October 14, 2019, 03:20:46 pm by Dennis »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2791
  • Hero Points: 422
Never mind about the scaling.  I finally revived my Ubuntu VM and see that the default dialog font is pretty large.  Just FYI, to use a smaller dialog font, go to Tools > Options... > Appearance > Fonts, then select Dialog, and change the font size from the default of 10 to 9.  That should make things work fine for your resolution.  Another option is for you to stick with the 10 point size and change the Dialog font to "Ubuntu" if you prefer their system font which is kind of heavy, but not as tall as DejaVu Sans.