Author Topic: Alias pop-u... oh, it's gone  (Read 345 times)

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2815
  • Hero Points: 426
Re: Alias pop-u... oh, it's gone
« Reply #15 on: November 08, 2019, 05:14:21 pm »
Try this:

1) Put the attached "autocomplete.e" in your config/hotfixes/ directory.
2) Load it (macro > Load Module...)
3) Do what you do to reproduce the problem.
4) Immediately afterward, go to the SlickEdit debug window and hit Ctrl+X to copy the contents
5) paste that information into a reply
6) Re-load the original <installdir>/macros/autocomplete.e

dunkers

  • Senior Community Member
  • Posts: 631
  • Hero Points: 28
Re: Alias pop-u... oh, it's gone
« Reply #16 on: November 08, 2019, 05:31:22 pm »
Er, how do I get to the SE debug window? Never needed it before...

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2815
  • Hero Points: 426
Re: Alias pop-u... oh, it's gone
« Reply #17 on: November 08, 2019, 05:33:52 pm »
Right-click on SlickEdit in the Dock, and select Show All windows.

dunkers

  • Senior Community Member
  • Posts: 631
  • Hero Points: 28
Re: Alias pop-u... oh, it's gone
« Reply #18 on: November 08, 2019, 05:40:59 pm »
This is Windows so there is no dock per se. Loading the macro gives me a window that lists a load of info lines - is that it? Anyway, this is what it shows when I do my thing:

Code: [Select]
AutoCompleteUpdateInfo: FOCUS WINDOWS NOT VALID
AutoCompleteUpdateInfo: FOCUS WINDOWS NOT VALID
AutoCompleteUpdateInfo: FOCUS WINDOWS NOT VALID
AutoCompleteUpdateInfo: FOCUS WINDOWS NOT VALID
AutoCompleteUpdateInfo: FOCUS WINDOWS NOT VALID

I get more of those if I hang about longer!

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2815
  • Hero Points: 426
Re: Alias pop-u... oh, it's gone
« Reply #19 on: November 08, 2019, 06:30:15 pm »
There should be more to it than just that.  I'm attaching another version with a little more debug.

dunkers

  • Senior Community Member
  • Posts: 631
  • Hero Points: 28
Re: Alias pop-u... oh, it's gone
« Reply #20 on: November 08, 2019, 06:44:27 pm »
just a little bit more this time! Attached.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2815
  • Hero Points: 426
Re: Alias pop-u... oh, it's gone
« Reply #21 on: November 08, 2019, 10:02:58 pm »
That did the trick.  Thanks for your patience and fortitude drilling down on this problem.  This will be fixed in the next hot fix for 24.0.0.

dunkers

  • Senior Community Member
  • Posts: 631
  • Hero Points: 28
Re: Alias pop-u... oh, it's gone
« Reply #22 on: November 08, 2019, 10:25:10 pm »
Blinding, thank you :)