Author Topic: The testCompile configuration has been deprecated for dependency declaration  (Read 113 times)

rowbearto

  • Senior Community Member
  • Posts: 1541
  • Hero Points: 113
I created a java gradle project. SlickEdit created the build.gradle. But it seems SlickEdit is using some deprecated features.

I get this warning:

Code: [Select]
The testCompile configuration has been deprecated for dependency declaration. This will fail with an error in Gradle 7.0. Please use the testImplementation configuration instead.
corresponding to this code:

Code: [Select]
dependencies {
    testCompile "junit:junit:4.12"
}

I am using Gradle 6.0.1.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1164
  • Hero Points: 110
Interesting. I'll add an item to my list to update that gradle template.  Thanks.