Author Topic: No more references.  (Read 3165 times)

dmain

  • Community Member
  • Posts: 17
  • Hero Points: 0
Re: No more references.
« Reply #30 on: June 17, 2022, 02:23:11 pm »
Yesterday references started working normally again. I switched from using a Remote Access Point (HW encryption device) to get the our company network to using our VPN. I thought that might have been the difference but when I went back to using the the RAP it is still working. I can almost guarantee that it will eventually break again. When it does I will see if I can determine what causes the difference. In the meantime is there a hot fix similar to the one that was provided to pineapple?

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3618
  • Hero Points: 481
Re: No more references.
« Reply #31 on: June 17, 2022, 02:59:49 pm »
That fix was integrated into the main development stream.

dmain

  • Community Member
  • Posts: 17
  • Hero Points: 0
Re: No more references.
« Reply #32 on: June 24, 2022, 05:11:20 am »
Today references are not working. Since they were working I moved locations. In the process I closed all Windows including SlickEdit. Turned off my Laptop. Went to the new location, different house. Turned on my laptop. Connected to my RAP, also moved with me. Opened SlickEdit and references are no longer working. I disconnected from my RAP. Connected to my wifi router directly. Established a VPN connection. SlickEdit references still do not work.

Graeme

  • Senior Community Member
  • Posts: 2724
  • Hero Points: 337
Re: No more references.
« Reply #33 on: June 24, 2022, 12:01:53 pm »
You could try this.  Close slick then rename vslick.sta to vslick.sta.bak.  Then restart slick.  If the problem goes away you could consider reverting to vslick.sta.bak and see if the problem comes back, maybe slick team can take a look at it.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3618
  • Hero Points: 481
Re: No more references.
« Reply #34 on: June 24, 2022, 06:12:04 pm »
Does the problem resolve if you do Project > Retag Workspace... (with "Retag modified only" unchecked), and then try the references search again?

If so, the next time it happens, send the before and after workspace tag files into support and I'll try to see what got broken.