Author Topic: Weird spacing while typing  (Read 572 times)

claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Weird spacing while typing
« on: February 07, 2020, 07:14:17 pm »
With the latest update, 24.0.1.0, while editing source files, weird spaces are bing inserted, or it appears to be so. When I try to remove a space it is deleting an actual character. It appears the cursor management is acting wonky. i.e.

final String  value ;

when opening in another editor is actually

final String value;

And if try to delete the space between value and semi-colon, it deletes the e in value.

like so: final String  valu ;

Very weird. I am hoping for a fix for this asap as it is highly annoying.

claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Weird spacing while typing
« Reply #1 on: February 07, 2020, 07:25:24 pm »
I tried reloading the prior version, and it is doing the same thing. So I suspect something in my config got messed up. It never did this in the prior version, and initially not so in the latest one. I am not sure what to delete and reset to correct the problem.

It would seem to me the cursor is skewed relative to data in the loaded buffer for the file.

This issue occurs intermittently. It doesn't matter wether the text being edited is a comment or a line of code.
« Last Edit: February 07, 2020, 09:16:04 pm by claylambert »

Graeme

  • Senior Community Member
  • Posts: 2447
  • Hero Points: 322
Re: Weird spacing while typing
« Reply #2 on: February 08, 2020, 05:48:57 am »
What do you mean by "reloading the prior version".  Did you somehow share your config folder between 24.0.0 and 24.0.1 - they should each have their own folder.

You might be able to fix it by deleting the vslick.sta file in your config folder  - with slick closed.  Alternatively, export your config (tools -> export), then start slick with a new empty config folder 
vs.exe +new -sc /some-empty-folder/
then import your configuration options.

claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Weird spacing while typing
« Reply #3 on: February 08, 2020, 06:58:17 pm »
Hi! No I wasn't sharing the config folder.. it used the older config folder that was still there for version 24.008... I will try what you suggested and report back what happens. Thanks!

Graeme

  • Senior Community Member
  • Posts: 2447
  • Hero Points: 322
Re: Weird spacing while typing
« Reply #4 on: February 08, 2020, 09:56:41 pm »
ok, that suggests that the problem might not be in slickedit or in your configuration, since it didn't happen to start with in the new version and now it happens in both versions.  You could try turning on special characters - in the view menu  - or maybe turn on just "other Ctrl characters". Also try turning on line hex.  Maybe try temporarily changing the document mode to plain text  - in the Document menu. 

Does it happen in all files? 
Is there anything common regarding the places in the code where the spaces appear?
What is the file encoding?

claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Weird spacing while typing
« Reply #5 on: February 10, 2020, 03:44:06 pm »
I have encountered this in JAVA source files and in editing .properties files.... I haven't noticed a pattern yet. It should not be processing any special characters.. but will turn it on and see if any are creeping in for some reason. I will have time later today to try and diagnose this aspect.

claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Weird spacing while typing
« Reply #6 on: February 10, 2020, 04:31:49 pm »
I tried resetting my config.. still occurs. Encoding was automatic, I changed it to US ASCII, still occurs.

It might be an issue with Slickedit and MAC OS X Catalina? As I upgraded to Catalina a couple of weeks ago.

I turned on viewing of special characters, nothing of note shows up.. However it shows a space with '.' and an additional viewable space without a '.'. I delete the space and the cursor deletes the '.' encoded space along with the blank space that gets inserted.

So it it inserts a normal space and an additional space, and the cursor moves over an additional character such that it looks like it moved by two, but is still locally associated with the prior character in the buffer.
« Last Edit: February 10, 2020, 04:35:00 pm by claylambert »

claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Weird spacing while typing
« Reply #7 on: February 10, 2020, 04:54:58 pm »
One pattern of note: When I use the final keyword in JAVA, it happens. And it happens a lot when typing in text for JAVA DOC comments.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1253
  • Hero Points: 120
Re: Weird spacing while typing
« Reply #8 on: February 10, 2020, 07:03:26 pm »

I seem to remember having seen something like this related to one of older per-language settings like truncation being turned on for a non-mainframe language, but I don't remember the exact details.

Can you post your user.cfg.xml from your configuration directory?  By default, the configuration directory is $HOME/.slickedit/24.0.1/ on Unix, or My Documents\My SlickEdit Config\24.0.1 on Windows.  I can take a look at the configuration for Java to see if I can reproduce or see anything strange.

Also, what font are you using for source code?  (long shot since it seems to be specific to editing Java files).


claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Weird spacing while typing
« Reply #9 on: February 10, 2020, 08:18:26 pm »
Here you go, thanks!

I am on a MAC OS X, Catalina... and using the 'Menlo' font.

claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Weird spacing while typing
« Reply #10 on: February 10, 2020, 08:24:00 pm »
I tried changing my font for Unicode Source files, and it seems to have corrected the problem... I will keep you posted as to if the correction persists or not. Interesting!

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5178
  • Hero Points: 429
Re: Weird spacing while typing
« Reply #11 on: February 11, 2020, 12:18:32 am »
All you have to do is use the "Ayuthaya" fixed font on Catalina and type "final". I reproduce this with v23 and v24.

It looks like a kerning issue. Kerning is supposed to be disabled but it looks like it's only half disabled.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5178
  • Hero Points: 429
Re: Weird spacing while typing
« Reply #12 on: February 11, 2020, 04:11:29 am »
This will be fixed for 24.0.2. Since we couldn't turn off kerning, selecting text across kerned characters will look ugly but still work.

Changing fonts will work since most fixed fonts don't have kerning.

claylambert

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Weird spacing while typing
« Reply #13 on: February 11, 2020, 05:27:00 pm »
OK cool! Yes changing my font settings seemed to do the trick in the meantime. Thanks for your attention on this issue! At present I am back to normal in my work. Take care!