Author Topic: [Beta 1]: Crashed for me twice now  (Read 364 times)

jc44

  • Senior Community Member
  • Posts: 286
  • Hero Points: 18
[Beta 1]: Crashed for me twice now
« on: July 30, 2020, 11:24:26 am »
Win10 x64: SE has crashed on me twice now.  Both times shortly after updating the files in my project.  First time I think I had added a few files and was looking for a symbol - that got me a "app has misbehaved reporting to MS" message. The second time I had just added a few 10s of thousands of files to a project (chrome) and was trying to open a file in it - this time SE just vanished with no error reporting.  Restarting SE and opening the same file worked OK.  Sorry this isn't a very helpful error report but I thought you should know.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1480
  • Hero Points: 133
Re: [Beta 1]: Crashed for me twice now
« Reply #1 on: July 30, 2020, 03:17:49 pm »
Good to know.  A minidump would be ideal, but your description gives us a few things we can try with instrumentation.  Let us know any other details you notice if it happens again.

jc44

  • Senior Community Member
  • Posts: 286
  • Hero Points: 18
Re: [Beta 1]: Crashed for me twice now
« Reply #2 on: July 30, 2020, 03:26:42 pm »
Other detail - all the source files are on a net mount (so fairly slow), indexes & config are on a fast SSD.
Remind me - where do I find the minidump?

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1480
  • Hero Points: 133
Re: [Beta 1]: Crashed for me twice now
« Reply #3 on: July 30, 2020, 03:36:55 pm »
If dumping on a user process crash is already enabled on your system, it should be in %LOCALAPPDATA%\CrashDumps

This document covers turning on the user process crash dump feature:
https://docs.microsoft.com/en-us/windows/win32/wer/collecting-user-mode-dumps?redirectedfrom=MSDN

The DumpType should be 1 for mini dump.

jc44

  • Senior Community Member
  • Posts: 286
  • Hero Points: 18
Re: [Beta 1]: Crashed for me twice now
« Reply #4 on: July 30, 2020, 03:50:21 pm »
OK I've turned the mini-dump on (I think) so if it happens again I should have more info.

Marcel

  • Senior Community Member
  • Posts: 251
  • Hero Points: 26
Re: [Beta 1]: Crashed for me twice now
« Reply #5 on: July 30, 2020, 09:43:33 pm »
I am seeing hangs a few times a day, usually after working for awhile (1-2 hrs).  No crashes, so far. SE spins on a CPU and becomes unresponsive.  I am as of yet unable to reproduce any of it. Some situations I can remember

a) During symbol lookup
b) During code completion
c) While loading a file into the current instance
d) While doing a git diff (maybe a different problem)

I'll keep my eyes open.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3235
  • Hero Points: 460
Re: [Beta 1]: Crashed for me twice now
« Reply #6 on: July 31, 2020, 02:41:49 pm »
@Marcel:  There is a known issue with the Slick-C math routines that leads to a hang, this is the likely cause of what you are seeing.  That will be fixed in beta2.  And it has no bearing on the crashes.