Author Topic: Beautify for "Makefile" disabled?  (Read 156 times)

at5dapa1

  • Senior Community Member
  • Posts: 213
  • Hero Points: 19
Beautify for "Makefile" disabled?
« on: September 23, 2020, 11:27:09 am »
I have a gnu makefile called "Makefile" and, when opened in SE, it's Document -> Select mode is "Makefile", the default mapping I guess.
If I try a beautification to convert spaces to tabs (not sure if that is possible though), I see that options from Tools -> Beautify -> ... are disabled.
Also the toolbar button "beautify_selection" (Beautify Selection or Entire Buffer) is disabled.

Is this intentional?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5702
  • Hero Points: 457
Re: Beautify for "Makefile" disabled?
« Reply #1 on: September 23, 2020, 12:56:10 pm »
Try using Spaces to Tabs (Edit>Other>Spaces to Tabs).

The beautifier doesn't support Makefile syntax.